Disk Partitions Gone Wrong...

Discussion in 'MacBook Pro' started by AppleFan22, Mar 5, 2015.

  1. AppleFan22 macrumors regular

    Joined:
    Jan 3, 2014
    #1
    So I had Yosemite for a while, and a couple of days ago I reinstalled Mavericks on a separate partition; they were running along side each other, and all was well. Today, I removed the Mavericks partition from Yosemite, using Disk Utility, and it worked, however, it has left it as "Free Space". Which is not what I want, as I was planning on installing Windows using Bootcamp soon.

    Despite trying to turn the Free Space into a Mac OS Extended (Journaled) Partition and then trying to erase that, it didn't work, it just wouldn't make the partition. The Log just says "2015-03-05 19:52:06 +0000: Preparing to partition disk: “APPLE HDD ST500LM012 Media”" but then nothing happens.

    Any ideas on how I can fix this, preferably very soon?
     

    Attached Files:

  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    What happened it Yosemite converted your drive to a core storage volume and that cannot be manipulated in Disk Util like you want.

    First try this command in Terminal to revert the core storage volume. Disconnect any other drives first.

    Code:
    diskutil cs revert /
    If that does not work you will need to backup the drive to an external and wipe the internal then restore the data back.

    To wipe to drive do a command-r boot to recovery the from the Utilities menu start Terminal and enter the command below exactly like I have it, including the quotes.

    Code:
    diskutil cs delete "Macintosh HD"
    Then quit Terminal are erase the disk back to one volume of Mac OS Extended (Journaled). Then quit Disk Util and restore from your backup.

    (If you don't know how to do the backup and restore, just post up and I'll explain that)
     
  3. AppleFan22 thread starter macrumors regular

    Joined:
    Jan 3, 2014
    #3
    The first method worked perfectly my friend! Thanks a lot!
     

Share This Page