Disk Permissions Failed: UPDATE

Discussion in 'MacBook Pro' started by TheGambler, Mar 27, 2011.

  1. TheGambler macrumors newbie

    Joined:
    Mar 10, 2011
    #1
    OK, so I ran verify disk permissions in Disk Utility and got this message:

    Disk Utility stopped verifying permissions on “Macintosh HD” because the following error was encountered:

    The underlying task reported failure on exit.


    Then I booted via the install disk, ran Disk Utility through that, repaired/verified disk permissions and got the same damn message!

    Do I have any other options besides having to wipe the hard drive clean?

    By the way I am running 10.5.8

    Thanks in advance!
     
  2. dumb terminal macrumors member

    dumb terminal

    Joined:
    Jan 15, 2008
    Location:
    San Diego, CA
    #2
    I ran into this issue about a year-and-a-half ago with an early 2008 MBP on 10.6.2.

    Disk Utility did nothing to fix the problem (which was caused by a failed Safari update).

    I ended up borrowing a copy of Diskwarrior 4.2 from a friend, and rebuilt the disk directory. It worked like a charm, and I didn't have to wipe my computer (which was great, because I didn't have a backup). Now I know better.

    Just something you could try.
     
  3. TheGambler thread starter macrumors newbie

    Joined:
    Mar 10, 2011
    #3
    Yeah I've heard good things about DW, I was just hoping I wouldn't have to shell out the money for it...
     
  4. macmikey2 macrumors regular

    macmikey2

    Joined:
    Jul 6, 2008
    Location:
    West Chester, PA
    #4
    Shell, Shell out now. Disk Warrior is a great tool for disks with issues. As a tech for over 20+years, I have used it way too many times and it has saved a lot of users butts in that time.
     

Share This Page