Disk stuck in 20" iMac

Discussion in 'iMac' started by Denton, Sep 25, 2008.

  1. Denton macrumors newbie

    Joined:
    Sep 25, 2008
    Location:
    St. Petersburg, Florida
    #1
    Hello all,

    I just wanted to ask specifically about one of the techniques used to eject a stuck disk. Can anybody say when you have to exactly hold down the mouse button when restarting? I've tried it dozens of times with no luck. Thanks in advance. :)
     
  2. Richard.John macrumors regular

    Joined:
    Sep 1, 2007
    Location:
    Yurigaoka, Japan
    #2
    Isn't there a keyboard command to do it? Option key plus the eject arrow next to the F12 key.
     
  3. BennyK macrumors 6502

    Joined:
    Sep 14, 2004
    Location:
    Appleton, WI
    #3
    I thought there was an emergency button you can hit with a paperclip in the drive... not sure though
     
  4. Chrycopsycho macrumors member

    Joined:
    Feb 5, 2008
    #4
    Open terminal and type the following, then hit return key to enter command:
    drutil tray eject
    Hope this helps
    Chris :)
     
  5. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #5
    On a MacBook you hold down the trackpad button on startup to force eject. I don't know if the mouse button would do anything or not.
     
  6. Denton thread starter macrumors newbie

    Joined:
    Sep 25, 2008
    Location:
    St. Petersburg, Florida
    #6
    Hey,

    I tried the Terminal cmd to no avail. Also, this is a Core 2 Duo iMac, so i'm not sure if there is an emergency eject button or not. I was just asking about the way where you hold down the mouse button to eject after restarting, because I know it works because I tried it the last few times a CD got stuck. And the keyboard command didn't work either.
     
  7. Buttercookie macrumors member

    Joined:
    Jun 2, 2007
    #7
    When I got a disk stuck I restarted and held down the eject button on the keyboard until the disk popped out. I'm at work and not near a mac but I'm pretty sure the button is in the upper right corner of the keyboard
     
  8. GSMiller macrumors 68000

    GSMiller

    Joined:
    Dec 2, 2006
    Location:
    Kentucky
    #8
    Well you've tried the Terminal command but what about the eject button on the keyboard, right clicking the disc and selecting "Eject," and dragging the disc icon to the trash bin to eject? If none of these don't work I'm at a loss, maybe doing it after a restart would work, or if you have Windows installed with Boot Camp, you could probably log in under that and try and eject it.
     
  9. steve_hill4 macrumors 68000

    steve_hill4

    Joined:
    May 15, 2005
    Location:
    NG9, England
    #9
    Mouse button on start-up works every time for me. You could also try going into Disk Utility and ejecting the disc from there, if you're trying to avoid a restart.
     
  10. Poncho macrumors 6502

    Poncho

    Joined:
    Jun 15, 2007
    Location:
    Holland
    #10
    Mouse button on start-up works every time for me.

    Same for me.

    Launching iTunes and clicking the eject-disc icon there also never fails to eject any disc in my drawer.
     

Share This Page