Disk stuck in optical drive - MBP

Discussion in 'MacBook Pro' started by Bigsy, Sep 14, 2009.

  1. Bigsy macrumors newbie

    Joined:
    Jul 3, 2009
    #1
    Hi,

    This is pretty urgent. I've got a late 2008 15 inch MBP (the one with the express card reader) and I put in a DVD and it wouldn't read it. As it didn't read it, I can't eject it, and this is pretty bad so if anyone could help me ASAP it would be much appreciated! thanks

    Bigsy
     
  2. jdechko macrumors 68040

    Joined:
    Jul 1, 2004
    #2
    Have you tried restarting the computer and holding down the mouse button? Also, you didn't specify, but it was a full-sized (12 cm) disc, correct?
     
  3. electroshock macrumors 6502a

    electroshock

    Joined:
    Sep 7, 2009
    #3
    Couple things to try:

    Hold down the mouse button at power-on (if you've got a two or three button mouse, use the left mouse button, I think)

    Press and hold down the eject button on the keyboard and see if it's persuaded to spit out the DVD

    In Terminal.app, type: drutil eject
     
  4. Bigsy thread starter macrumors newbie

    Joined:
    Jul 3, 2009
    #4
    Thanks!!

    I tried drutil eject and it worked, but what's more worrying is my MBP now wont read any dvds... this has only happened since I upgraded to 10.6.1 ( I upgraded straight away after the install.) I don;t know whats causing this problem, and these are dvds that worked with 10.5.8...

    Anyone out there had the same problem/have a solution?

    Cheers


    EDIT: yes, it was a normal disk. I just put in a CD and it read that fine, I will try another DVD in a second.
     

Share This Page