Disk utility can't find new hard drive

Discussion in 'PowerPC Macs' started by JR10X, Aug 18, 2010.

  1. JR10X macrumors newbie

    Joined:
    Aug 18, 2010
    #1
    So... I have a dual 1.25 ghz MDD Powermac G4. It was working fine until a couple of days ago. It froze up, I restarted it. I got a blank blue screen. Also, the computer made some awful clicky noises that I've never heard before.

    I booted from the OS X installation CD. Disk utility lists the WD1800 hard drive, but I can't do a re-install and there's no option to repair it. I can't erase or partition it because when I try, I get a failure message saying it can't be done ("chosen size not valid for chosen filesystem"). The HD is listed in system profiler... with a capacity of 0 bytes.

    I assumed that the hard drive had died, so I went to a local PC shop and bought the only IDE drive they had (a Maxtor 6l250r0). I installed it, then booted from the OS X CD. I know that new hard drives need to be formatted, but I assumed that this could be done with disk utility. But disk utility can't find the new hard drive, doesn't list in the left column. It shows the optical drives and the install CD and the old WD hard drive which can't be erased or repaired, but no new hard drive. It's not listed in the system profiler, either. I checked the cable connections and tried installing it in the front carrier rather than the rear, but nothing works - disk utility and system profiler can't recognize it.

    The only other desktop mac I have access to right now is my old 450 mhz Sawtooth G4. I tried putting the HD into the sawtooth and got the same results - disk utility and system profiler can't find the new HD at all, but has no trouble finding the old 20gb HD and the DVD and zip drives.

    I'm... not really sure what to do here. Am I doing something wrong? This is the first time I've tried installing a hard drive, so it's possible that I've just put in in wrong (several times), but looking at the manual and online tutorials, I'm sure I followed the instructions carefully, and that the drive is attached correctly with the right jumper settings.

    If I need to format it before disk utility can find it, how do I go about doing that? Or is it just that the new HD is bad, or maybe isn't compatible with old G4 powermacs?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I suggest setting the master/slave selector on the new drive just like the old drive has it, then swapping them. I don't think the Sawtooth will see this drive unless it's preformatted because of the less then 120Gb only thing. Your MDD does not have this restriction.
     

Share This Page