Disk Utility - Can't format/initialize external HD

Discussion in 'Mac Accessories' started by Beliblis, Jul 26, 2014.

  1. Beliblis macrumors regular

    Joined:
    Dec 31, 2011
    #1
    Hi,

    I just had my main laptop (MBP) crash. Won't boot anymore. So am using my old Macbook with OS 10.7 installed.

    Today I used Disk Doctor twice, trying to reformat two external hard-drives. On both occasions, formatting the drive failed. The error message was "Mediakit reports driver bundle not found".

    One drive was a Crucial M4 SSD (256GB), the other is a Seagate Momentus 500GB, both in DIFFERENT external enclosures. So I'm pretty sure the problem lies with my system / OS.
    Whatever I tried – I could not get to format the hard drives, and on both drives I lost the initial partition. I also can't repartition it...
    I tried Drive Genius – same problem.

    I tried Disk Drill, and Disk Drill at least finds the old partitions.

    I am not worried about data loss – I just want to format the drive. (Or recover the partition, and if there's no way of formatting it I'll just delete the files that are on the drives...)

    Has anyone got any recommendation on how to proceed?
    2 different drives – 2 different softwares (Drive Genius / Disk Doctor), and I just can't format a drive. How weird is THAT????
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    Did you try the OS disk utility (utility folder) or just the aftermarket apps?

    Anytime you reformat a drive or partition you will lose the data.

    Did you try erasing the drives before formatting.

    The only time I've had issues formatting was when there was a hardware problem in the drive or enclosure.

    Are the drives getting enough power?
     
  3. Beliblis thread starter macrumors regular

    Joined:
    Dec 31, 2011
    #3
    Yes, I have used Apple's Disk Utility from the Utilities Folder. As well as Drive Genius.
    The drives have enough power – as a matter of fact, I've been using them day in & day out, copying & backing up data for hours without any problems.

    Once the drives were backed up to other drives (3.5"), I simply wanted to erase / format them.
    Ultimately I want to put them as an internal HD into that MBP which died on me. (I think it's the current internal HD that's causing the problems on the MBP).
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Likely some system software issue that is interfering with disk management.
    Boot to your Macbook's Recovery system (Restart, holding Command-R)
    At the menu screen, choose Disk Utility.
    Plug in your external drive, choose it in the Disk Utility window.
    Be sure to choose the manufacturer's info line for the device, and not a named partition.
    Click the Partition tab.
    Change the Partition Layout from Current, to 1 Partition.
    Name the partition, if you like, then click the Apply button.
    That WILL remove all data on the device, but it sounds like that's what you want.
     
  5. Beliblis thread starter macrumors regular

    Joined:
    Dec 31, 2011
    #5
    I updated the system just now - from 10.7.4 to 10.7.5 (like I said before... "emergency" Macbook which lives in the bookshelf most of the time ;)

    And that solved the problem. I could finally format the two drives without problems. (Formatted it Mac OS Extended (Journaled), GUID)

    I am now in the process of copying my Macbook Pro's backup (which is on a 3.5" drive) to one of the 2.5" drives so I can use as an internal system HD.
    (Using Carbon Copy Cloner).

    I noticed the original system HD says "Version: 10.9.4" in the Info panel. The newly formatted drive (GUID/Journaled) doesn't say anything. Will that "Version" info automatically added once I use the drive to boot up the MBP?
    Or is there something I'm missing here?
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    Hi,

    formatted (erased) drive = no OS installed ---> no OS "version".

    Once your backup is cloned to the formatted hard drive, an OS will be there, and the version info will show up.
     
  7. Beliblis thread starter macrumors regular

    Joined:
    Dec 31, 2011
    #7
    That makes sense –*thanks for verifying!

    By the way:
    The problem with my broken MBP looked VERY much like either a RAM or a GPU / motherboard problem: graphics artifacts, crashes – remaining artefacts straight after restart as soon as the apple logo came up,...

    This happened a few times, until it wouldn't restart at all. (Though there was always a chime at least).
    Long story cut short: once I removed the HD and did a reboot into recovery mode (OS downloaded from the web), there were no graphic artefacts anymore at all. Will have more certainty once I've done a proper reboot from the new internal HD – will report in a separate thread in more detail once everything worked out fine.

    Like I said: I was prepared for the worst (new motherboard). Very surprising that there is a good chance it could be the hd.
     
  8. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH

Share This Page