Disk Utility can't format internal SSD

Discussion in 'Mac Basics and Help' started by joelhietala, Jul 31, 2012.

  1. joelhietala macrumors newbie

    joelhietala

    Joined:
    Jul 31, 2012
    Location:
    Finland, Europe
    #1
    Hi all!

    First of all, let me specify that I'm not new to Mac. I'm new to MacRumors. I've tried out several Apple communities, but I didn't like the UI nor the atmosphere. Oh, and the 64GB SSD is installed by me, and it has worked fine for about three months. But anyways, my problem.

    (I don't think it's a hardware-specific problem.)

    A couple of days ago I restored Mountain Lion's InstallESD.dmg to an external 8GB USB drive without problems. I booted from the drive and left OS X installing on my iMac (early '08, Core 2 Duo @2.8GHz, 64GB internal SSD, external HDDs) and went to watch the Olympics.

    When I got back, the iMac was stuck on a grey screen with a blinking folder and a question mark. I decided to boot from the aforementioned USB drive to fix possible problems and disk permissions. Disk Utility said that there were no problems.

    However, the iMac was still unavailable to boot. (Blinking folder and a question mark.) I held down the Option key while booting, and selected the internal SSD. It managed to boot! I was on Mountain Lion's lovely desktop. I shut down the machine, and then the problems started.

    The following day, when I started the iMac, the blinking folder and question mark screen was there again. I rebooted with the Option key held, and the internal SSD wasn't there to be seen. I wasn't on the boot device screen.

    Long story short, I then installed Lion (not Mountain Lion) on my external HDD without any problems. Once I booted to Lion, I opened Disk Utility and the internal SSD wasn't in the list of disks. I turned the mac off for the night.

    The following morning (today) I booted to the external HDD of my iMac, opened Disk Utility and noticed that now the internal is on the list again. But. All of the buttons and text fields are grayed out, I can't format the disk. The partition is now called "disk1s2" and it's spelled with gray text. When I click the partition, it says that the location is "Not visible". When I click the "Make visible" button, nothing happens.

    So what should I do? Please help.
     

    Attached Files:

  2. icomputered macrumors member

    Joined:
    Oct 19, 2011
    #3
    Even though I don't have this issue, and clicked on this thread by accident, thank you for posting a solution to this problem. In the future, some person with this problem will be thankful that you did.
     

Share This Page