Resolved Disk utility-Could not unmount disk

Discussion in 'Mac OS X Lion (10.7)' started by macdudesir, Nov 24, 2011.

  1. macdudesir, Nov 24, 2011
    Last edited: Nov 24, 2011

    macdudesir macrumors 6502

    Jan 16, 2011
    I messed up the partitions on my MBP and now, trying to erase the entire hard drive and restore, when I click erase on the drive, disk utility says Could not unmount the disk even though the two partitions are greyed out on the side bar and can be unmounted manually by clicking unmount but then when i click erase again, i get the same error.:confused:

    Help would be greatly appreciated!
  2. zigzagg321 macrumors 6502

    Oct 7, 2011
    the wire

    This happened to me after I ran Bootcamp. Later on, I wanted to ditch Windows and I wanted to get rid of the partition I had made for it and what you describe is what was happening to me. I ended up having to reinstall Lion from the recovery partition of the HDD.
  3. macdudesir thread starter macrumors 6502

    Jan 16, 2011
    That's what I was going to do, but out Internet connection is slow. I ended up using the snow leopard install cd to reformat the whole drive. It was saying could not unmourned because it wanted to unmount the whole hard drive and it couldnt because the recovery partition is on the drive and was being used. But with the cd, the drive was inactive. Thank you for your input though! ;)

Share This Page