Resolved Disk Utility creating wrong partition sizes

Discussion in 'OS X El Capitan (10.11)' started by milaround, Nov 6, 2015.

  1. milaround macrumors member

    milaround

    Joined:
    Dec 5, 2007
    #1
    Pretty straightforward problem:

    1. Partition an external 4TB disk into 2TB/1TB/1TB
    [​IMG]

    2. Get totally screwed up partition sizes:
    [​IMG]

    What is going on, and how do I create the partition sizes that I want?
    10.11.1 all software updated to latest.
    Thanks for any help!
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    I remember when I was creating partitions on one of my new hard disks, I saw correct 1.5TB and 500GB, not any weird number. But I did this under an early beta of El Capitan 11.10.0.
    Apple screws this up in official software?
     
  3. milaround thread starter macrumors member

    milaround

    Joined:
    Dec 5, 2007
    #3
    It appears I have solved the issue; Here's the rest of my journey for anyone else who may have this issue:


    Starting from the above screen shot:

    Tried to re-partition the existing partitions into a single 4TB
    Failed with error:
    [​IMG]

    Erased main drive, yielded a 4TB partition. Partition map showed a non-removable 0kb "Untitled" partition.
    [​IMG]

    Proceeded to partition as 2/1/1TB (Note the odd-looking graph)
    [​IMG]

    The "Untitled" partition is gone, and Disk Utility shows the partitions correctly on the graph, but is missing a partition on the list.
    [​IMG]

    Quitting/Restarting Disk Utility now shows the previously missing partition. All seems well from this point.
    [​IMG]
    Seems like buggy native software. Sad to see... I will report back if something goes wrong.
     
  4. ataractic macrumors newbie

    Joined:
    Sep 10, 2008
    Location:
    NJ
    #4
    --- Post Merged, Oct 12, 2017 ---
    I've seen similar issues repeatedly when trying to partition disks using disk utility in El Capitan. I'm not sure when this bug was introduced, but it is very concerning to see a something as essential as disk utility apparently not being tested enough before release. I guess the focus is shifting more and more to shiny new features rather than the core OS. I use terminal to partition my disks now. Sad indeed...
     

Share This Page