Disk Utility dead in Leopard?

Discussion in 'macOS' started by sturob, Oct 28, 2007.

  1. sturob macrumors regular

    Joined:
    Nov 20, 2005
    Location:
    Houston, TX
    #1
    Hey,

    So I successfully installed Leopard on two machines on Friday night with no apparent problems. I repaired permissions on both beforehand, yada yada . . . but. . .

    Afterward I decided to repair permissions once more after I'd gotten everything settled. So, I ran Disk Utility, and it just sits there. No progress, no nothing. I tried to run it from the terminal (sudo diskutil repairpermissions /) and it just sits there with 0% progress.

    Did they break Disk Utility? I noticed that the Disk Utility on the Leopard install DVD is version 11, just like what I have on my computer.

    Thoughts?

    Stuart
     
  2. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #2
    Can you repair permissions from the Leopard Install DVD? I know there is access to the terminal and Disk Utility from the actual installer.
     
  3. SpinThis! macrumors 6502

    Joined:
    Jan 30, 2007
    Location:
    Inside the Machine (Green Bay, WI)
    #3
    How long did you wait? If you run top in terminal, is there anything happening while diskutil is working?

    For me, there's apparently another process "installdb" that runs first and sucks up the majority of the cpu. It does eventually complete though.

    I did a search at Apple... nothing on "installdb" or what it actually does. man pages show nothing. I guess we wait until Apple posts a knowledgebase article on it...
     
  4. Wayfarer macrumors 65816

    Wayfarer

    Joined:
    Jun 15, 2007
    #4
    Repair permissions worked for me after waiting a while. Have you tried waiting long enough?
     
  5. flir67 macrumors 6502

    Joined:
    Jun 23, 2005
    #5
    yeah, same here, YOU GOT TO WAIT , not screaming just its strange why we have to wait and I mean wait for this great process.

    this leopard reminds me of 10.0 release very very buggy... it will take 6 months updates,etc.. to get it working right.
     
  6. Sojourn macrumors member

    Joined:
    Oct 29, 2007
    #6
    I'm glad I'm not the only one noticing this. I've stopped the Permission Repair a few times now, thinking that something might be wrong. Weird, though, that even after I quit Disk Utility, "installdb" kept running. Now that it's stopped, however, I'm going to go and see if I can get my permissions repaired.

    Take care,
    Sojourn

    EDIT: I waited it out, and it took about five minutes to finish.

    Not to hijack the thread (if I am, let me know and I'll start a new one), but this is what was displayed in the window:

    I've never seen something like this on my machine after a permissions repair -- it seems like it found problems, but won't repair them. Any ideas?
     
  7. AJsAWiz macrumors 68030

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #7
    I had the same problem while I was on the phone with Apple Care. The Apple Specialist had no idea why there was no progress when we tried to repair permissions. I may call back at a later date and talk to a different person.
     
  8. Foxer macrumors 65816

    Foxer

    Joined:
    Feb 22, 2003
    Location:
    Washington, DC
    #8
    I had the same message when I installed Leopard, although everything seemed to work. I just went ahead a re-installed Leopard and got no error message.

    And my repair permissions is very, very slow as well.
     
  9. jskess macrumors newbie

    Joined:
    Nov 2, 2007
    #9
    Problems with disconnecting disks

    Since installing Leopard, and running an AEBS with three drives and two printers connected to it, I continually have problems with the disks disconnecting, while the printers continue to work fine. When I try to connect to the server through the Go menu, it doesn't work. If I try to go through the shared sidebar, the disks appear, but can't be accessed.

    Because of this I'm stuck restarting several times a day, which gets annoying.

    Anybody else had this come up?

    Any fixes?

    Thanks.
     
  10. Sojourn macrumors member

    Joined:
    Oct 29, 2007
    #10
    So a reinstall fixed it for you, Foxer? Did you do an erase and install? I just upgraded my Tiger install, so that I wouldn't lose any preferences, applications, etc. I'd really rather not have to reinstall to begin with, but especially not an erase and install.

    Also possibly of note -- I went ahead and tried to repair my permissions again this evening, and did not receive the same message -- all of the "should be 0, user is 95." lines were gone, and there was only one error listed (again, one that it said it would not repair; unfortunately, I don't remember what the message was, and whether it was exactly the same (though it was pretty similar, at least) as that first line I had posted earlier). Weird stuff.

    And sorry jskess, I'm afraid I haven't had your problem --I've actually had less trouble ejecting external hard drives than I did in Tiger, come to think of it. Hopefully someone else can help you out!

    Take care,
    Sojourn
     
  11. Omek macrumors regular

    Joined:
    Jun 6, 2003
    #11
    Same Here...

    My disk utility is acting up as well. First I did an upgrade install with Leopard on my 17" Powerbook and on my mom's intel mini as well. Both machines get the same error messages. They are a slew of permissions that disk utility won't repair....

    And disk utility takes forever as well. All though it sped up slightly after I upgraded to 10.5.1


    I then did an erase and install after I got a new external hard drive for Christmas, and I still get the messages. Hopefully they fix this soon...
     

    Attached Files:

Share This Page