Disk Utility error: Invalid Leaf Record COunt

Discussion in 'macOS' started by lowonthe456, Jul 30, 2008.

  1. lowonthe456 macrumors 6502

    Joined:
    Oct 27, 2007
    #1
    what utilitiy fixes this?

    full error:
    Verifying volume “Macintosh HD”

    Performing live verification.
    Checking Journaled HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Invalid leaf record count
    (It should be 623360 instead of 623358)
    Checking multi-linked files.
    Checking Catalog hierarchy.
    Checking Extended Attributes file.
    Checking volume bitmap.
    Checking volume information.
    The volume Macintosh HD needs to be repaired.

    Error: Filesystem verify or repair failed.
     
  2. vniow macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #2
    Run fsck in single user mode. Post back with results.
     
  3. lowonthe456 thread starter macrumors 6502

    Joined:
    Oct 27, 2007
    #3
    ran fsck and it showed same error. said it had modified the disk, ran fsck again and it came out fine...rebooted and ran disk util and it checked out. I guess I had so few problems i had completely forgotten about fsck

    thanks!
     
  4. DizzyDeane macrumors newbie

    Joined:
    Aug 28, 2008
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    Start in single user mode and follow the directions on screen.
     
  6. DizzyDeane macrumors newbie

    Joined:
    Aug 28, 2008
    #6
    Tanx, Sun Baked, that worked!!!

    I typed '/sbin/fsck -fy' & igorned many 'Found a transaction which hasn't moved in 5 seconds ...' errors. I kept on typing until it came up clean. Rebooted & ran OnyX -- I'm good to go <whew>. I didn't know abt Cmd-S. Tanx again.

    Aloha, (Mr.) DizzyDeane
     
  7. lisarose macrumors newbie

    Joined:
    Dec 26, 2008
    #7
    fsck works!!!

    it ran thru it's "repairing" twice before i got volume repaired but now everything ok.

    lisa
     

Share This Page