Disk Utility quits when formatting as Encrypted Drive

Discussion in 'Mac OS X Lion (10.7)' started by hanguolaohu, May 15, 2012.

  1. hanguolaohu macrumors regular

    Mar 5, 2007

    I'm trying to format my external hard drive as Mac OS Extended (Journaled, Encrypted), but every time the progress bar displays "Waiting for logical volume to appear", I get a pop-up window stating "Disk Utility quit unexpectedly". I've formatted many hard drives this way, and am not sure why I'm getting this message on this particular hard drive. I formatted as Mac OS Extended (Journaled) without a problem. The drive is in an enclosure, connected via FireWire. I rarely experience Disk Utility quitting like this. Could the hard drive be corrupted? I'm on an MacBook Pro, so it's not possible for me to do a S.M.A.R.T. test on the drive.




    Update: On the "First Aid" tab, I hit "Verify Disk" and got this message:

    Verifying partition map for “OEM”
    Checking prerequisites
    Checking the partition list
    Checking for an EFI system partition
    Checking the EFI system partition’s size
    Checking the EFI system partition’s file system
    Checking all HFS data partition loader spaces
    Checking Core Storage Physical Volume partitions
    Checking storage system
    Problems were found with the partition map which might prevent booting
    Error: Storage system verify or repair failed.

    I then hit "Repair Disk" and got the same message. Any way to fix this drive? Or is it dead??? :confused:

  2. hanguolaohu thread starter macrumors regular

    Mar 5, 2007
    Update 2: I just tried formatting a 2nd hard drive the same way, Disk Utility quit, then I verified disk and same "Error: Storage system verify or repair failed." Could my enclosure or Mac Mini be a drive killer???
  3. Revearti macrumors member

    Oct 29, 2011
    I'm running into the same problem, but I don't with my MacBook Air. Here is what I posted on this thread earlier today. I'm not an expert, but from various tests, I think your Mini is fine and FV2 is the problem.

    Also, try running verify disk on the partition and not the disk and see if you get the same result. Either way, I don't like the error message that is displayed when running verify disk on the actual disk itself.


    I think FV2 is the problem because of random results. I just formatted my Mini (2010) and Air (2010) with my Lion 10.7.4 USB key. After completing minor updates on both, I enabled FV2 without any problems. Then I wanted to create encrypted external drives with FV2. The following problems occurred:

    (1) I formatted both drives with zeros (not encrypted) without any issues.
    (2) If I do a quick encrypted erase using the Mini with FW 800 or USB 2, Disk Utility crashes.
    (3) If I do a quick encrypted erase using the Air, Disk Utility does not crash.
    (4) If I verify the disks using the Mini or the Air, I get the following message: "Storage system verify or repair failed."
    (5) If I verify the actual partition using the Mini or the Air, everything is okay.

    With these random results, I can't trust FV2 at this point. I'm worried something disastrous could happen in the near future.

Share This Page