disk utility repair futility

Discussion in 'macOS' started by Wie Gehts, Mar 6, 2008.

  1. Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #1
    Hey folks...
    this is really starting to get my goat, to put it nicely.

    Whenever I happen to get a 'disk needs to be repaired' and then run the disk utility repair from my installation disk, it has always so far, reported that the disk didn't need any repair after I run it.

    For example, my computer was acting a little strange so I ran Onyx. It told me the hd needs repair. So I run off the installer and, of course, it says no repairs needed. And when I reboot from my hd and run onyx or disk utility, it says it needs repair. The freakin' repairing off the installer disk never works. Its becomes a vicious cycle. It always has done this and now I'm really irritated.

    What usually winds up happening is that after shutting down and using the computer a few times, it'll go away.

    Am I supposed to shell out a 100 bucks for disk warrior for what this &*!%^* useless and pointless disk utilty is supposed to do in the first place?

    Thanks :)
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    1. Restart your computer while pressing the key. (This causes the computer to startup in Single-User Mode. You will see a fullscreen commandline interface.
      [*]At the command prompt, type fsck -fy. (This runs File System Check and forces the OS to accept repairs repairs to your hard drive.)
      [*]If any repairs are performed, then rerun the fsck -fy until no additional repairs are required. If fsck identifies problems but doesn't seem to repair them, then you should shutdown your system until a qualified technician can examine it.
      [*]If your system is reported to require no additional repairs, then type either exit or logoff. (Either will do.)
      [*]After going through a lengthy routine, your computer should eventually return the traditional MacOS X GUI.
     

Share This Page