Disk Utility says there are problems with partition map

Discussion in 'macOS' started by zak0, Jan 18, 2016.

  1. zak0 macrumors newbie

    Joined:
    Nov 2, 2015
    #1
    I'm running El Capitan 10.11.2 on my early 2011 MBP which I have upgraded with a Samsung 840 EVO SSD.

    I had been running Linux Mint alongside OS X for a while. Recently I removed all the Linux partitions and resized my OS X partition to use the entire disk. I did the resizing using OS X Mavericks that I have on an external HDD (could not modify the partitions if booted into anything on the SSD). After this all seems to be OK and the computer boots just fine with no visible errors or any other problems.

    However, I wanted to be absolutely sure that all was OK after messing with the partitions. So after the operation I ran El Capitan's Disk Utility's First Aid for my SSD and it says that "Problems were found with the partition map which prevent booting".

    [​IMG]
    Is this something to worry about? It bothers that it says there are errors without specifying what errors and then still saying "Operation successful"...
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Questions:

    Does the volume in question still boot?
    Or no?

    Can you run Disk Utility's first aid/repair function again, say, 3 or 4 times in succession?
    What kind of report do you get each time?
     
  3. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #3
    Do you get the same error if you run Disk Utility a second time? Maybe it fixed it the first time? When you ran Disk Utility , did you run in while booted from the Recovery Partition?
     
  4. zak0 thread starter macrumors newbie

    Joined:
    Nov 2, 2015
    #4
    Yes, this is my boot drive and it boots up just fine. OS X is installed on the partition labeled "Mac" that is shown in my screenshot.

    I get the same exact output for First Aid every time I run it, no matter how many times I run it.

    The Disk Utility that is shown in my screenshot is run from OS X El Capitan that is booted from that same drive. For the partitioning of the drive (the SSD in the screenshot) I ran Mavericks from an external USB HDD, that acts as my "recovery boot" option.

    If I run First Aid for the partition, it goes through without any warnings or errors.

    In fact, I have removed the recovery partition from my SSD as it was inconveniently placed on the drive when I needed to make room for Windows and Linux. I couldn't figure out how to move it using disk utility, not sure if it's even possible...
     

Share This Page