Disk Utility unable to repair Macintosh HD

Discussion in 'macOS' started by Artmuzz, Dec 11, 2009.

  1. Artmuzz macrumors 6502

    Joined:
    Jun 17, 2008
    #1
    Hi,

    I have a MacBook with 3 partitions. One has Snow Leopard (Macintosh HD), Tiger and Windows 7

    On Snow Leopard I tried to backup files to my external Hard Drive but some files wouldn't transfer. When I clicked on the folder that was unable to transfer, everything went out of control. All windows started opening themselves and I had to shut down my MacBook by the power button.

    When I tried to restart my MacBook it just sticks at the white screen and grey apple logo with the timer icon. I then decided to insert the Snow Leopard DVD and repair the disk through Disk Utility to no avail:( According to Disk Utility my Snow Leopard partition cannot be repaired and it has unmounted the Snow Leopard (Macintosh HD) icon:(

    When I boot onto my Tiger partition I cannot see the Snow Leopard icon so i could backup my data.

    I have tried everything. I have tried doing the firewire Target disk mode but the only icon disks that appear are Tiger and Windows 7. I have also tried doing an archive and install but there isn't enough disk space for to reinstall Snow Leopard.

    How can I mount the Snow Leopard disk so I can access it and backup the files and data I have in Snow Leopard?

    Please advise


    Art
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I suggest you pick up either disk warrior or tech tools and hopefully one of those utilities can help you.

    Sounds like your partition got corrupted, or worse your drive itself is going south.
     
  3. Artmuzz thread starter macrumors 6502

    Joined:
    Jun 17, 2008
    #3
    I had to take the hard drive out of my Macbook and put it into an USB external hard drive enclosure where I connected it via USB to my other Mac.

    I managed to get the Snow Leopard drive show up on the desktop where I was able to backup the files and data I had on that disk.

    I then reformatted the partition Mac OS Journaled using Disk Utility and repaired partition successfully and no errors found but for some reason I cannot install Mac OSX on that partition. Once Mac OSX is successfully installed on that partition it doesn't boot and when I go to disk utility it tells me that there are errors on the disk and it cannot be repaired.:confused:

    Please advise

    Art
     
  4. Artmuzz thread starter macrumors 6502

    Joined:
    Jun 17, 2008
    #4
    I finally managed to install Leopard and boot into that but now I have new problems:mad::apple::mad::apple::mad::apple:


    Art
     
  5. myuserid08 macrumors 6502

    Joined:
    Mar 15, 2008
    #5
    Backup all your data on the disk from the 3 partitions.
    Download a linux live disc and run badblocks (read and write) this will test and destroy all data. If it passes the drive is ok.
    Format the drive (1 partition) and re-install SL.

    I know this isn't the easiest solution but it beats losing data either now or further down the line.
     

Share This Page