Disk Utility upon bootup gives different result

Discussion in 'macOS' started by nickdag, May 10, 2012.

  1. nickdag macrumors newbie

    Joined:
    Jan 2, 2011
    #1
    Hi there,
    MBP13 2010 OS X 10.7.4
    Intel 320 Series SSD (300GB)
    USING FILE VAULT 2

    When I run Verify Disk in Disk Utility from within my login, I get the following error:
    Problems were found with the partition map which might prevent booting
    Error: Storage system verify or repair failed.

    When I bootup using Cmd-R and then using Disk Utility and repeating the process, I get an OK result.

    Is this a bug? A problem? A result of FV2?

    Any ideas?

    Thanks,
    nick
     
  2. nickdag thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #2
    Thanks for the feedback. Unfortunately in my case I haven't run Verify in ages and have no comparison to previous versions.
     
  3. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #3
    @nickdag:
    I would try this:
    1. Quit Disk Utility.
    2. Open a Terminal window, and type:
    sudo /Applications/Utilities/Disk\ Utility.app/Contents/MacOS/Disk\ Utility
    (or something similar)
    then enter your admin password.

    This launches DU with administrator privileges (not super user privileges).
     
  4. Azathoth macrumors 6502a

    Joined:
    Sep 16, 2009
    #4
    Similar issue here
    MBA13 2011 with FV2 - only since 10.7.4 (I ran DU on 10.7.3 a few days before the "upgrade" and it was fine)

    Would have though that by the 4th service pack Apple would have a stable OS...
    :(
     
  5. JohnRocks macrumors member

    Joined:
    Dec 2, 2010
    #5
    My guess is that since Disk Utility couldn't see the hidden recovery partition and since that partition is physically AFTER the Lion partition it could not resize. But by mounting the hidden Recover Partition, then Disk Utility was able to move the Recovery Partition and expand the Lion partition.
     
  6. Revearti macrumors member

    Joined:
    Oct 29, 2011
    #6
    I think FV2 is the problem because of random results. I just formatted my Mini (2010) and Air (2010) with my Lion 10.7.4 USB key. After completing minor updates on both, I enabled FV2 without any problems. Then I wanted to create encrypted external drives with FV2. The following problems occurred:

    (1) I formatted both drives with zeros (not encrypted) without any issues.
    (2) If I do a quick encrypted erase using the Mini with FW 800 or USB 2, Disk Utility crashes.
    (3) If I do a quick encrypted erase using the Air, Disk Utility does not crash.
    (4) If I verify the disks using the Mini or the Air, I get the following message: "Storage system verify or repair failed."
    (5) If I verify the actual partition using the Mini or the Air, everything is okay.

    With these random results, I can't trust FV2 at this point. I'm worried something disastrous could happen in the near future.
     
  7. Ilbabgui, Dec 13, 2016
    Last edited: Dec 13, 2016

    Ilbabgui macrumors newbie

    Joined:
    Dec 11, 2016
    #7
    This thread is old, but I have somewhat similar problem.

    Disk Utility in normal mode (log in from administrator account) or from Command R shows everything is normal, but when I do it in Safe Mode I get this:
    [​IMG]

    Is this a bug? I wouldn't even know about it if not for random testing using Safe Mode.

    When I had Sierra, Disk Utility didn't even want to run in Safe Mode when doing this scan on Apple HDD, just popping window saying the thing about partition map. Back to El Capitan, it now looks like that.
     

Share This Page