Disk Utility won't erase iMac drive

Discussion in 'iMac' started by VideoBeagle, Sep 17, 2014.

  1. VideoBeagle macrumors 6502a

    Joined:
    Aug 17, 2010
    Location:
    App Q&A testing by request.
    #1
    I have a late 2012 27" iMac.

    I was taking it to the Apple Store to fix The Mechanism™ broke. (The tilt hinge). As I knew fixing it would entail leaving the iMac there for several days, I cloned my drive and erased the iMac.

    HOWEVER, when trying to do it, both form a USB install drive I set up AND from the Recovery Partition, Disk Utility would fail to erase the drive. It would quit and go back to the install drive directory.

    I then booted back to the regular drive, manually dragged most of the stuff to the trash and emptied it. I then went back to the USB drive and tried one last time.

    This time, the drive reformatted like it was supposed to. I tried again, it worked again.

    I loaded Mavericks on, and packed the iMac up and went to the store (where it is now).

    The "Genius" had no idea why the erasing didn't work earlier, and since things now did work, I couldn't replicate. They're diagnostic scan showed everything was good.

    It's the 1TB + Fusion drive.

    BEFORE I manually erased everything, there was around 120 gb free on the drive. After there was 900+gb free.

    Anyone seen anything like this? Have ideas what was happening?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    It sounds like your Fusion setup is broken. Try following the steps at the bottom of this page to fix it then erase.
     

Share This Page