Disk utility won't open after upgrade to twin drives

Benbikeman

macrumors 6502a
Original poster
May 17, 2011
616
0
London, England
I've upgraded my mid-2009 MBP 17 with two 1Tb Western Digital 9.5mm drives (one mounted in the DVD bay using an Optibay adapter). The drive in the main bay is the boot drive, and both drives work perfectly.

However, Disk Utility won't open - it just hangs with the spinning beach ball. I've even tried leaving it open overnight but the beach ball remains.

Lion 10.7.2, fully up-to-date with software updates.

Any ideas?
 

Detrius

macrumors 68000
Sep 10, 2008
1,621
19
Asheville, NC
Take a look at /var/log/kernel.log while Disk Utility is hanging. It may spit out disk I/O errors, which would point to either a bad drive or a bad cable.
 

Benbikeman

macrumors 6502a
Original poster
May 17, 2011
616
0
London, England
Thanks for that. Could you tell me the full path? Neither Spotlight nor I can find the file (I did the search while Disk Utility was hung and repeat it after force-quitting it).
 

Benbikeman

macrumors 6502a
Original poster
May 17, 2011
616
0
London, England
No matter - it was a corrupted preferences file (off-forum suggestion to delete the plist files in Preferences). Deleting those and restarting cured it. :)
 

Detrius

macrumors 68000
Sep 10, 2008
1,621
19
Asheville, NC
For the record, that was the full path. It's a hidden folder, but Console.app will show you the contents.

Technically, /var is a symlink to /private/var, but still... same result. Both /var and /private are hidden, so it's not shown in the Finder, and Spotlight won't show you anything inside of either folder.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.