Disk Warrior can't rebuild directory.

Discussion in 'MacBook Pro' started by mrk1234, Jun 27, 2016.

  1. mrk1234 macrumors newbie

    Joined:
    Mar 3, 2014
    #1
    I'll try keep this to the point.

    Macpro 2011 (early) 13"
    500gb
    16gb
    10.7.?

    Turned on and the grey screen and spinning wheel. Tried to verify disk and a host of other things like ram reset and nothing. Tried to reinstall OS but after 18 hours it still said 1 hour 20 mins left. Even tried Ethernet cable and froze right away.
    Then tried disk warrior and it says 'the directory of the disk 'name' cannot be rebuilt'. 'The disk is in use. Quit all other applications. Or restart from disk warrior disc the try rebuild again'.

    I have managed to get a few files off I think. But my 500gb external is mac formatted or with NSTF or whatever it is called. It won't let me copy files from mac to my external in the dual pane window of disk warrior file thing. So I had to use a simple little 16gb pen drive and copy what could and now that 16bg won't show up on my little pc notebook!
    I was up last night till 1 and I've been sorting this today from 5pm to 11pm. Getting a pissed off now. What the hell is going on.

    I was speaking with Apple support online who are very helpful and have ran me through some tasks but still nothing. They said they will send me a 1tb hard drive external to duplicate drive and try a full erase and restore. Which is nice of them. But that's gonna be Friday (5 days) and I need to get something sorted. Why is disk warrior not able to sort my HD out. Will this be able to repair. Am I best getting a new HD now? (I don't have too much spare cash right now).

    Any advice ideas much appreciated.
     
  2. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #2
    Did you do what Disk Warrior told you to do, and boot from the CD? It sounds like it can't do its major repair functions on the same disc. That's why it's giving you the error. DiskWarrior is the best, and if it can't fix your problem your disk is probably dying.
     
  3. mrk1234 thread starter macrumors newbie

    Joined:
    Mar 3, 2014
    #3
    Hi. Yeah I booted from th DW disc that was in my cd drive. Is that what you mean? Am I doing it right?
     
  4. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #4
    Yes, that's what you needed to do. For some reason DW still thinks the disk is being used for something. Do you have any other disks connected to the machine? You can try googling the error and seeing what you find, or contacting DW tech support.

    if you've recieved all the files off that you need to, you can try reinstalling, but erasing the disk via disk utility in the installer first.
     

Share This Page