Disk Warrior Error 2153, 4903 - disk is still in use...

Discussion in 'MacBook' started by Cian1118, Feb 25, 2013.

  1. Cian1118 macrumors newbie

    Joined:
    Feb 25, 2013
    #1
    Hello I am posting on the forums today because I urgently need help to save the files on my hard drive!
    So it all started when I booted up my MacBook Mid 2009 a while ago. The grey bar appeared under the apple logo while booting. It got to the end and then shut off immediately. So I tried fixing things and it all worked fine when I got disk warrior. I got into my hard drive and tried to back it up but it froze so I had to turn it off. When I restarted it booted straight to the recovery drive (mountain lion). The disk is there and I verified and repaired. Failed again. Booted into disk warrior, the computer being very slow. After d/w inspected the drive it gave me this: the disk cannot be rebuilt. The disk is still in use. Error code 2153, 4903.
    Now I understand that I must use terminal in the recovery drive to kill the process stopping disk warrior.
    I believe I have found it using: ls -la /Volumes/
    But how so I kill it because there is no PID so the kill command tells me it's not a process. Please help! If you want me the copy and paste the stuff that comes up when I do ls -la /Volumes/ please ask.
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    Are you booting to a Disk Warrior DVD or external drive? If not, then you're using the Recovery Partition -- on the volume you're trying to repair. That's why it's in use.

    I'm surprised how often I still see people with no backup. PLEASE backup your files -- or you WILL lose them.
     
  3. Cian1118 thread starter macrumors newbie

    Joined:
    Feb 25, 2013
    #3
    Thanks for the reply.
    I'm booting to the diskwarrior DVD.
    Using the terminal in recovery (which is on the INTERNAL HD) I've found what I think is the application that's stopping disk warrior. I know that the recovery is a partition of the internal HD but when I done the commands in terminal it tells which partition it's on, which is Macintosh HD.

    The real help I need is getting help using terminal to close the app I have found. I can't use the kill command because no PID (process id) shows up for after doing command: ls -la /Volumes/
     
  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    That command just lists the mounted volumes. It does not list processes.

    Check out the Terminal command "top", which will show you the active processes.
     
  5. Cian1118 thread starter macrumors newbie

    Joined:
    Feb 25, 2013
    #5
    When I type that in on the recovery terminal it's says command not found, although when I done it on my friends mac which is functioning properly it worked. So I need a different command that works in the recovery
     
  6. madmacmaster macrumors newbie

    Joined:
    Dec 5, 2013
    #6
    Disk Warrior 'Disk still in use'

    Can someone lay out all steps to execute these commands in terminal to a non expert? Can not rebuild directory. Tried everything mentioned here and other forums.

    I've shut down every program, tried everything except in Terminal.

    thanks
     

Share This Page