Disk Warrior won't boot from disc

Discussion in 'Mac Apps and Mac App Store' started by rednote, Sep 15, 2008.

  1. rednote macrumors newbie

    Joined:
    Nov 30, 2007
    #1
    I bought D.W. today, Rev. 42. It will not boot up from the disc on Leopard 10.5.4, it just keeps restarting the machine when I hold down "C". Any suggestions?

    Thanks,
    Rod
     
  2. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #2
    What Mac are you trying to boot with the disk? I know that the Early 2008 Mac Pros as well as a couple of other models are still not able to be booted from the DW disk latest version. I was looking at their site the other night hoping that they have updated that since I have a MP that won't boot from it, but no luck so far.

    I went to the site tonight to check on the full list of machines that DW disk booting will not work with so I could let you know, but unfortunately the site is down presently. Try here when the site is up and check the compatibility notes: http://www.alsoft.com/DiskWarrior/index.html

    BTW, when booting from the DW disk the version of OSX on your machine does not come into play since DW boots its own version off the CD.
     
  3. sidneyssa macrumors newbie

    Joined:
    Oct 19, 2008
    #3
    I believe that DiskWarrior 4.2 is for Snow Leopard.
    You will need DiskWarrior 4.1 for Leopard.
    "I had the same problem. I had Leopard installed and tried to run DW 4.2 it didn't boot, but when I run 4.1 it did".

    And bear in mind what machine you are running it. See link...
    [ http://forums.macosxhints.com/archive/index.php/t-94020.html ]
     
  4. J-Fry macrumors newbie

    Joined:
    Jul 6, 2010
    #5
    Soooo... what you're saying is: in a year nobody has figured out how to boot a Snow Leopard macbook pro 2008 (exactly what I have) with Diskwarrior from the CD yet?

    Those links are all
    "how to do it"

    doesn't actually discuss what to do when it doesn't, in fact, boot from the CD.

    I keep rebooting even when holding C, even when trying 'startup disc'.

    Which is strange (very) because I used to have 10.4 OS on this machine and DW worked very fine.
     
  5. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Try to boot holding option instead of C and manually select the drive you wish to startup from.
     
  6. J-Fry macrumors newbie

    Joined:
    Jul 6, 2010
    #7
    I cannot boot from the DiskWarrior 4.3 update disc either by holding C, by holding option (doesn't show up), nor by startup disc.

    Something's up with the relationship between Snow Leopard and the version of OS on Disk Warrior.

    Tech support was of no help; so I am looking at such workarounds as creating an external OS drive with Diskwarrior ON IT so I can boot from that.
     
  7. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #8
    Use an external USB or firewire drive

    That is the easiest way to do it. Just connect an external USB or firewire drive, either clone your present system if it is healthy enough, or install the OS from a DVD, and copy the Disk Warrior application to the Application folder on the external drive.
    Boot up from the external drive, holding down the option key at bootup, and run Diskwarrior, which will pop up a dialog box the first time you run it, and then you can run DW against the internal drive. :cool::D:cool:
     
  8. spencercross macrumors newbie

    Joined:
    May 21, 2010
    #9
    Just to confirm, I have the same problem with the newest version of DW, 4.3, and an early 2009 iMac running 10.6.6. I'm about to install Snow Leopard on an external drive solely as a boot disk from which to run DW.
     
  9. barkwolf, Apr 4, 2011
    Last edited: Apr 21, 2011

    barkwolf macrumors newbie

    Joined:
    Apr 4, 2011
    Location:
    Berk. CA
    #10
    DW is pretty disfunctional

    I too have had these problems. i've easily wasted 10 hours screwing around with the 4.3 DW trying to get it to boot up. Their tech 'help' have told me to; burn it to DVD instead of CD-R, don't use the bluetooth keyboard, but my old plugin kb, add a code into Terminal, and a hundred other things. It always says the 'disk is Locked' and will only Graph, never rebuild. I've tried to unlock everything and used Installer disk, etc. I've been pulling my hair out, I'm so disgusted. Of course, before Snow Leopard, everything always worked. I think Microsoft made Snow Leopard for apple, it's been so much trouble since I've installed it! I guess I'll try the Terminal code up here and also try the old 4.2 and see if it will work. :mad:

    I still never got it to boot, but I didn't see the Option key trick until today. I'll try THAT next. I hate Snow Leopard. My Mac's have never been so messed since they introduced it.
     
  10. thermodynamic Suspended

    thermodynamic

    Joined:
    May 3, 2009
    Location:
    USA
    #11
    2011MBP here (17"). v4.3 causes a kernal panic almost instantly.

    Using the option key and using the arrow keys, that is how I selected the optical disc (DVD+R). I did the cmd/opt P+R combo to reset the EFI and then tried again, which also did not work. :(

    (v4.2 did not work, hence my looking for an update... and DriveGenius 3 warned me of two files being corrupt that prompted me to try to boot with DiscWarrior to fix the drive...)
     

Share This Page