Disk write permissions removed

Discussion in 'macOS' started by kalakov, Jul 29, 2011.

  1. kalakov macrumors member

    Joined:
    Apr 4, 2011
    #1
    hi im using os x lion and i got the message an unexpected error occured (-50). After this i could not write anything on disk. I repaired disk permissions and everything was fine but a couple of hours later the same thing happened. please help.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Permissions

    Have you tried a repair using Onyx? It's still beta, but I'm using it on my iMac with no problems at all.....It's free too. Make sure you download the Lion only version.

    Backup prior to using it. It can take quite a while, so be patient while it does it's stuff.
     
  3. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #3
    Sometimes a reboot will fix anomalies like this. I occasionally get the same thine on my Time Machine drive.
     
  4. kalakov thread starter macrumors member

    Joined:
    Apr 4, 2011
    #4
    repaired permissions twice. once is DU and second with onyx. permissions damaged again. any ideas? reboot doesn't help.
     
  5. kalakov thread starter macrumors member

    Joined:
    Apr 4, 2011
    #5
    ok so i've erased my hd and reinstalled OS. I didn't install any additional apps for a few days and it kept working fine. Then I began the Software update and also began installing MS Office. During this process I got the same error again and both activities got cancelled automatically.

    Rebooting fixes this problem. But it keeps cropping up repeatedly and it's getting on my nerves. Anyone with a different approach on how to resolve this issue permanently.

    I know this is not confined to Lion because I was getting it in SL as well. Please help!
     

Share This Page