"disk0s2: I/0 error. Invalid node structure..."

Discussion in 'MacBook Pro' started by cdmac, Jan 28, 2011.

  1. cdmac, Jan 28, 2011
    Last edited: Jan 28, 2011

    cdmac macrumors newbie

    Joined:
    Jan 28, 2011
    #1
    Hello everybody,

    Firstly, this is my first post on the forum; my name is Craig and I'm just the average Mac fan.

    I bought a MacBook Pro in August 2009, and everything has been great with it, up until now:

    A few days ago, my Mac was running incredibly slow, even minimising windows was taking well over 60 secs! I decided to try and do some 'house cleaning' of the Mac; deleting photographs, moving things to an external hard drive etc. Just general up-keep. I spent a lot of time doing this, and hadn't completed it, but it was getting on so I just shut down my computer as normal.

    When I went to boot up my computer the next time, it just wouldn't get past the Apple logo with the spinning cog, I googled a few things, I tried the PRAM solution, booting up from my Snow Leopard install disc and using Disk Utility (which couldn't repair!!!!).

    I then tried safe mode, entered 'fsck' command (I have done so several times) this is what returns:

    ...
    ** Checking catalog file.
    disk0s2:I/0 error.
    Invalid node structure
    (4, 32260)
    ** Rebuilding catalogue B-tree.
    Disk full error
    ** The volume Macintosh HD could not be repaired.
    /dev/rdisk9s2 (hfs) EXITED WITH SIGNAL 8
    :/ root#

    Now all I seem to be able to find on google is DiskWarrior or re-formatting the HD and starting over? Are there any other options? If I were to need to re-format, would I be able to retrieve any photographs already on the HD?

    I guess there's a lesson for me to learn: back up more regularly!!!!!


    Thanks for taking the time to read,

    Any help would be greatly appreciated,

    Craig

    EDITED TO ADD: I apologise in advance if the topic has already been covered
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    This:

    disk0s2:I/0 error

    You have a bad hard drive. If you care the least about your future data, you won't try just to fix it; you'll replace the hard drive. If you don't care about future data on the drive, you could reformat, zeroing all data. That might remap that bad blocks, but you still have a drive that has produced bad blocks.
     
  3. RaceTripper macrumors 68030

    Joined:
    May 29, 2007
    #3
    +1
    Replace the drive. If you open Console and do a search for "I/O error" and see more of these, then your data is living on borrowed time.

    I also had a mid-2009 MBP and it's drive went bad after 6 months, replaced under warranty.
     
  4. cdmac thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #4
    Thank you for your feedback!
    Apologies for the delay in thanking...
    Is there any way I could retrieve data from the HD before/after I replace it?

    This is typical, I'm off on a holiday to New York in just under a fortnight!

    Thanks again,

    Craig
     
  5. mseneshen macrumors newbie

    Joined:
    Feb 28, 2011
    #5
    Hi! This is my first post on this forum too. I have the same error, and are also wondering how to backup my data. I cannot backup using Disk Utility on the OS X cd, because it also gives the disk0s2: I/O error message, and I cant start up. Also, I am pretty experienced with computers. When I was opening my preferences folder, when I was able to start up, or in single user mode, trying to ls the Preferences directory, it took forever in single user mode, and doing it in finder froze, and I had to force quit. I think that is because of the node structure error. How can I backup? I really need this data...

    Thanks in advance! Please respond ASAP.
     
  6. mseneshen macrumors newbie

    Joined:
    Feb 28, 2011
    #6
    Oh, never mind. I haven't checked out the DiskWarrier website until now. I thought it was only disk error fixing, not safe recovery. I will try DiskWarrier.
     
  7. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #7
    You can also try to do dd to another disk in single user mode. Hoping that dd allows you to skip over the bad blocks and still retain some of your information for later retrieval.
     
  8. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #8
    ddrescue (the one without the underscore) is much better. Don't run Disk Warrior on a bad drive. It's possible to use it for data recovery, but it's not safest.

    The best approach really just depends on your data. If you only need a few files, and the disk still mounts, you could just focus on the files. As a professional, I generally use ddrescue and then run DW on the disk image.
     
  9. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #9
    Pretty nifty tool. This is actually the first time I have heard about it. Usually UBCD just uses dd for drive duplication.

    Thanks!
     
  10. Ysulyan macrumors member

    Joined:
    Sep 4, 2008
    #10
    I have to say, as a professional, ddrescue did save my big fat butt this time!

    With a hard faulty sector problem on the HDD, there's nothing more you can do other than back out everything as much as you can, and in my case, all existing tools failed big time with the sector error (S.M.A.R.T. raw read error ID 0x01), and I have to mention it is a ****** Samsung (seagate) 1TB 9mm ultrathin one. I now go with WD Scorpion Blues 1TB as primary internal hdd and it's pretty darn good so far.

    Just need to mention that Clonezilla should have done a awesome job, but the --rescue option dragged for too long and I had to cancel and booted to Derbian kernel only uisng Clonezilla boot disk, and ran the command line ddrescue -f -n /dev/source /dev/target without any log file..I could have made it better with log file and such for resuming purpose but I was so desperate to back data out and back to production.

    ddresuce is your friend!
     

Share This Page