DiskAid not working with 3GS 3.1.2??

Discussion in 'Jailbreaks and iOS Hacks' started by olimits7, Oct 14, 2009.

  1. olimits7 macrumors member

    Joined:
    Sep 30, 2009
    #1
    Hi,

    I'm trying to use DiskAid with my 3GS 3.1.2 iPhone, but I'm receiving some errors when connecting and then trying to transfer files.

    First, when I connect I receive this message:

    "Sorry, you need to have a Jailbroken device to view the root partition."

    But my iPhone is Jailbroken, I used Blackra1n to Jailbreak my iPhone; so I don't know why it says this. Anyway, my iPhone then connects to the folders/files, and then when I try to "Copy File to Device" I receive this message:

    "Error opening destination file (/ROMs/NES/****.NES). Close any other application on your device that may be locking this file."

    Is anyone else having this issue with a 3GS 3.1.2 iPhone with DiskAid?? Is there another program I can use instead that will work??

    I would just use WiFi and OpenSSH, but I don't have a WiFi where I'm currently at; so I want to use a USB connection.

    Thank you,

    olimits7
     
  2. olimits7 thread starter macrumors member

    Joined:
    Sep 30, 2009
    #2
  3. IBradMac macrumors 68000

    IBradMac

    Joined:
    Jun 27, 2008
    Location:
    Ohio
    #3
    Yeah I was pretty disappointed as well when I tried to get into the root partition using diskaid. :eek:

    I used the a new release from Cydia called afc2add and problem solved. ;)
     
  4. olimits7 thread starter macrumors member

    Joined:
    Sep 30, 2009
    #4
    Ok, great...thanks "afc2add" worked like a charm and a lot easier to do than the link I posted!! :)
     
  5. FSUSem1noles macrumors 68000

    FSUSem1noles

    Joined:
    Feb 23, 2006
    Location:
    Ft. Lauderdale
    #5
    Yeah, this is a known issues with JB'ing with BlackRa1n
     

Share This Page