diskutil doesn't see new HDD

Discussion in 'Mac mini' started by tomsky007, Feb 14, 2012.

  1. tomsky007 macrumors newbie

    Joined:
    Feb 14, 2012
    #1
    Hello,
    My old HDD crashed recently and I had to order a new harddrive. I installed the HD and everything but it doesn't show up in the disk utility or the installer.

    First I thought I bought a broken harddrive or there is some problem with the mini. But the I booted into xubuntu from a livecd on the very same mini. And there I can see the HDD fine; I can format it, read write ... whatever I want to do.

    I already tried writing zeros all over it in linux, formatting with different partition tables. But it won't show up in the installer.

    Anyone can help me with this?


    Thanks!
     
  2. tomsky007 thread starter macrumors newbie

    Joined:
    Feb 14, 2012
    #2
    i now installed snow leopard via firewire on the mini. it still doesn't see the hdd (stop sign when booting up; no hdd in diskutil when starting from cd).

    Please, can anyone help?
     
  3. Cmd-the-World macrumors regular

    Joined:
    Apr 7, 2010
    #3
    We can help you if you give us more details on your system.

    Which Mac Mini do you have?
    What kind of drive are you installing? (Hybrid Drive or Normal Drive or SSD)
    What OS are you trying to install on it? (Lion, Snow leopard, Leopard)

    As far as I know the only partition table Mac OS X is able to install on is GUID.

    From what I am understanding you have another Mac in the house. Can you remove the hard drive from the Mini and connect it via USB to your other Mac?

    Using something like this (if you don't have any enclosures): http://eshop.macsales.com/shop/NewerTech/Voyager/Hard_Drive_Dock

    When you connect it to your other Mac is Disk Utility able to see the hard drive?
     
  4. tomsky007 thread starter macrumors newbie

    Joined:
    Feb 14, 2012
    #4
    Thanks for your reply. It is a 2006 mini 1.1 (core duo 1.66GhZ). The harddrive is a standard Samsung 2.5" 5400 60GB SATA Drive. I bought it to replace my failed fujitsu HD.

    I tried installing Tiger from the original CD, and also tried Leopard and snow leopard from their repective retail DVD. But all have the same problem - diskutil only shows the CD/DVD.

    I don't have a HD enclosure. However I can format and access the actual harddrive in the same mini when I boot xubuntu from a live-cd. And yes - I can also access th HD fine when the mini is in target mode. Thus, I'm pretty sure that the HD is not defect.

    I managed to install OSX (snow leopard) using my MBP and putting the mini in target disk mode. Now when the mini starts it shows the stop sign after a while instead of the question mark folder. I still can't see the HD in diskutil though when I start from DVD.
     
  5. Cmd-the-World macrumors regular

    Joined:
    Apr 7, 2010
    #5
    I don't know what exactly is your cause of trouble but I think I might be hardware related (maybe there is a pinched wire or something). Since you managed to install Snow Leopard try and run the Apple Hardware Test maybe there is a faulty hardware.
     
  6. tomsky007 thread starter macrumors newbie

    Joined:
    Feb 14, 2012
    #6
    Well - I was thinking about hardware failure too. But why can I access the HD in linux and via target disk mode? If it would be windows or linux I would suspect a missing driver but with Macs that seems unlikely...


     

Share This Page