Diskutil Raid & Boot Disk Issue

Discussion in 'macOS' started by apetrovic, Jan 15, 2009.

  1. apetrovic macrumors newbie

    Joined:
    Jan 15, 2009
    #1
    Hello
    I just switched from PC to Mac and have an issue I was hoping someone could help me with.

    - I own an iMac 24" iMac6,1 and a firewire 800 external drive
    - After doing some research online I was under the impression that it was possible to set up a software raid between the imac and firewire external drive. Looks like I was mistaken (or it is not recommended).

    I attempted to set up a software raid using the following steps:
    - Boot iMac using Leopard install disks
    - Open Terminal
    - Use following commands to format and select drives to mirror (I no longer have the specific commands)
    -Restart and repair mirror...

    Needless to say this did not work that well...sometimes the computer would recognize the drive and sometime it would not. So I decided not to mirror the drives and just use SuperDuper. I deleted the raid set from disk utility and erased both the external and internal drives and started from scratch. This was all done from the installed operating system and not the install disk.

    When I formated the partition I noticed that the drives still kept their slice labels (disk0s2 and disk1s2). Also, when I restarted the computer and held down the option key my iMac internal HD is listed twice as a boot option. When I click on the the first copy to boot from the system works fine. when I click on the second one a do not disconnect symbol pops up during the white startup screen and replaces the apple.

    So here are my questions:

    1) How do I remove this 2nd copy of my iMac HD?

    2) Why are the disk identifiers coming up as disk0s2 and disk1s2 instead of disk0 and disk1 or disk0s1 and disk1s1? this mean that the initial raid partnership still exists somewhere in the system files (since the mirror was established using the install disks with terminal)? If so how do I remove that partnership? I tried diskutil from the install disk and noting came up...is there another location?

    4) Do I need to reformat my internal HD...would that solve the problem? And if so could I use superduper to clone my information back to the original drive and retain my settings?

    5) Why does my system get stuck during startup when my ipod (in disk mode), or my external drive, is connected to the computer?

    My theory is that something is left over from the original raid setup because the disk identifiers still have slice labels and they are not in numerical sequence like disk0...disk0s1 and disk1...disk1s1. Also when I open the raid tab in disk utility for eack drive the default name for the raid is "Untitled RAID Set 1" and not just "Untitled RAID Set". Which makes me believe that there is still some residue left over from the initial raid. Which could explain the duplicate drive listing and the hangups when external drives are connected..could be an attempt to make the mirror association. Is this a hardware/firmware issue?

    Any help would be appreciated. Thank you.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    You could try resetting the PRAM first. Reboot the computer while holding command+option+P+R until you hear the startup chime a second time.

    Yes and yes. This is the way I'd go if the PRAM doesn't work.

    Beats me.

    Firmware maybe, hardware no. I think the format should clear things up.
     
  3. apetrovic thread starter macrumors newbie

    Joined:
    Jan 15, 2009
    #3
    Thanks for the reply.

    I have tried the PRAM and it did not resolve the problem.

    I have used the restore disks provided with the computer to erase and reinstall the operating system, but the two drives still show up.

    Is there a way to erase or reformat the internal drive that will guarantee no info will be left behind?

    Thanks
     
  4. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #4
    I would boot from the install DVD, select Disk Utility, and erase/reformat your internal disk before you attempt a reinstallation. Just using the erase and reinstall option does not AFIAK reformat the drive.

    Using a software RAID with the boot drive has got to be tricky, as the OS has to boot before the RAID can be utilized, but if the boot drive is part of a software RAID ........ you get the chicken and egg situation here.
     
  5. apetrovic thread starter macrumors newbie

    Joined:
    Jan 15, 2009
    #5
    I had a hardware raid setup on my previous pc and hoped that this software setup would work just as well...I was wrong. Not a big deal because Superduper does basically the same thing...great app with its scheduling feature.

    Well blodwyn your suggestions worked. The duplicate drive is no longer there. I erased the drive using the install disk and disk utility...then transferred the superduper backup to the internal drive and now the system is up and running...soooo much easier than the headaches I experienced with pc's in the past.

    Thank you both for the suggestions.
     

Share This Page