Display/typing delays and freezes

Discussion in 'MacBook Pro' started by jbischke, Feb 1, 2009.

  1. jbischke macrumors newbie

    Joined:
    Jan 27, 2009
    #1
    Hey all. Recently upgraded from an older MBP to a new unibody MBP with a 2.4 Ghz CPU and 2 GB of RAM. Running 10.6.5. On my old machine I was noticing something strange where I'd see a "stuttering" of sorts. iTunes and other streaming music services were choppy and occasionally my mouse pointer would freeze up for a moment. I figured moving to new hardware would help.

    Well, it hasn't seemed to.

    Although the iTunes choppiness has gone away on the new machine, I'm still noticing the display/typing delays. Often I'll go to type something and I'll be 10 letters or so in before I actually see the letter pops up on the screen. The mouse seems to freeze as well. This seems to happen mostly when I've switched to a new app and begun to type rather than when I'm typing within the same application. It's intermittent as well. I don't always notice it.

    Has anyone else noticed a similar problems. It's really slowing me down. If I was on an old machine I'd be more inclined to accept but since I'm running fairly top the line hardware it seems off. Also, my CPU isn't anywhere near maxed and I have plenty of available memory.

    Any suggestions?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Try a reboot. That fixes quite a few things. See if it repeats afterwards.
     
  3. jbischke thread starter macrumors newbie

    Joined:
    Jan 27, 2009
    #3
    Oh, I've done that. :) And quite a few other things. Including...

    -I've reset the PRAM.
    -I've repaired disk permissions.
    -I've installed Macaroni and run through all the maintenance tasks.
    -Made sure all software updates were applied.

    Now some of these things I did on my old machine so I guess a possible next step is to run through all of these steps on the new machine. Probably couldn't hurt right?

    Any other suggestions?
     
  4. jbischke thread starter macrumors newbie

    Joined:
    Jan 27, 2009
    #4
    I think I figured this out. I noticed in Activity Monitor that Firefox was spiking every few seconds and that this spike correlated perfectly with my mouse lag/freeze. I switched to Camino and the problem has not returned. It's a bit of a bummer because there are some things I like about Firefox that Camino doesn't have. However Camino is a much faster browser and that plus curing my system of the freezes and choppiness is well worth it.
     

Share This Page