Display won't sleep

Discussion in 'MacBook Pro' started by DesmoPilot, May 17, 2010.

  1. DesmoPilot macrumors 65816

    Joined:
    Feb 18, 2008
    #1
    Noticed today the display on my MBP won't sleep; this is what I've done/tried thus far:

    - Gone though my programs and none of them seem to be the culprit.
    - Quitting every app and leaving the computer idle with nothing running, display still doesn't sleep.
    - Double checked system preferences and made sure nothings conflicting.
    - Also of note, the screen saver will trigger and work fine.
    - Permissions repair did nothing

    Any idea's?
     
  2. silencer88 macrumors member

    Joined:
    Jul 14, 2009
    #2
    I always thought the screen saver and the display sleep were on the same timer. That is, if the screen saver timer is engaging, then the display sleep should also engage. Is there some specific action that can keep the display awake but not cancel the screen saver?

    I would create a new user and test there. Maybe you have a background process running that's causing this... I can confirm that my display sleeps properly (15" i7)
     
  3. DesmoPilot thread starter macrumors 65816

    Joined:
    Feb 18, 2008
  4. Azusa macrumors newbie

    Joined:
    May 3, 2010
    #4
    Steam?

    Do you have Steam installed? I've noticed some strange behavior with display/system sleep since I installed Steam. After testing things, it appears that sleep gets broken after you run any game in Steam. The only remedy I've discovered is a reboot.
     
  5. Dragonforce macrumors 6502a

    Dragonforce

    Joined:
    Apr 9, 2008
    Location:
    London (Ealing) UK
    #5
    I have the same issue and I can confirm its Steams fault.
    Pretty annoying.
     
  6. doktordoris macrumors 6502a

    doktordoris

    Joined:
    Mar 14, 2009
    #6
    Forum Rules.

    Bumps. Posts that bring a thread to the top of the New Posts list but add no content to the thread (bumps) are not permitted. This applies not only to posts that say "bump" but to those with the intent to bump, e.g. posts saying "anyone?" or the equivalent.

    Just thought you might like to know.
     
  7. DesmoPilot thread starter macrumors 65816

    Joined:
    Feb 18, 2008
    #7
    So you bump a thread to tell me that? Heh.

    Anyways yeah, found out it was Steams fault. Thanks for the heads up guys.
     

Share This Page