displaying web pages loacally

Discussion in 'Web Design and Development' started by petec, Nov 5, 2007.

  1. petec macrumors newbie

    Joined:
    Nov 5, 2007
    #1
    Hi. I have just started using Dreamweaver on an iMac, having used it previously in a Windows environment.
    I cannot figure with the Mac how to display pages locally as can be done with Windows (via ISS in LocalHost)

    My Dreamweaver help say press alt+F12 to do so but omits how to set up the equivelent of ISS first.

    Can any one enlighten me please ?
     
  2. rajfantastic macrumors member

    rajfantastic

    Joined:
    Jun 9, 2007
    #2
    go to system preferences > sharing and turn on personal web sharing. it will then give you a URL which is the root of your Sites folder. You may have to install apache/php/mysql if your site uses those technologies.
     
  3. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #3
    Are you using any server side technology like databases or server side Java?

    If not, then Dreamweaver does not need any local server environment at all, it renders the Includes itself and previews directly in your browser of choice (and a second browser, with an alternate f12 combination)
     
  4. petec thread starter macrumors newbie

    Joined:
    Nov 5, 2007
    #4
    displaying web pages loacally

    Thanks for the info guys...

    I have turned on 'personal web serving in System preference like you advise.

    When I press Alt + F12 however I then get displayed the Sound box but not the webpage.

    Any ideas ?

    PS I am using ASP/VB Script and will later use with MySql

    Many thanks again...

    Pete
     
  5. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #5
    I don't believe browsers other than IE can handle VB Script, not sure about ASP, think it's fine. Do you have any code you can provide? Maybe something you have isn't compatible with the Apache web server.
     
  6. petec thread starter macrumors newbie

    Joined:
    Nov 5, 2007
    #6
    displaying web pages loacally

    Many thanks for that Angelwatt.

    Wheter apache can handle vbscrupt is another issue... My problem is much more fundamental than that...

    I have also tried with an html page with just a line of text on it; I cannot get it to display in the browser either ! (So vbscript is not my problem - yet)

    Having set set system preferences + sharing and turning on Personal Seb Sharing - it says to 'veiw this computers website at http://10.0.1.4/.

    My site is located in a folder called 'Mysite'
    If I press alt+F12 keys I get the sound box on the screen, not the browser.
    If I click the 'Preview/Debug browser' icon on the top toolbar in Dreamweaver I am given a choice of browsers but when I select one of them - say Safari - I get a web page with the error message 'Not Found'

    The address shown in this page is http://127.0.0.1/TMP3UC3R2SGR.html.
    The 'Not Found' html page is the temporary page produced by dreamweaver to display.

    The bit I am missing is how do I make the browser look at the 'Mysite' folder where the page is on the hard drive ?? (In Windows one sets the address of the homepage by selecting the folder where the test site is stored.
    That I think is my problem. in that I cannot figure out the way to link the browser to my site folder.
    It's most frustrating :D

    May I just add that I have come to iMac from using Windows for some time. I do know how to use Dreamweaver in Windows.
    Also I have no literature, other than the little book which came with the iMac so am really in the dark at the moment.

    A quick way out of course is bootcamp + Windows XP and back to what I know - but I really dont want to do that...
     
  7. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #7
    Well if you're using the default web server setup with the Mac then your site should be able to be pulled up from a site like, http://localhost/~username/ (note: localhost = 127.0.0.1). This assumes that the web pages are located in the ~/Sites/ folder (~ = your home directory). It sounds like you may need to move your folder to this Sites folder.

    From the file name you gave the Dreamweaver is trying it sounds like it's working from a temp file. I vaguely remember having a problem like that with Dreamweaver, but it was over a year ago so don't remember if i solved that problem. I don't use Dreamweaver anymore, just don't care for it. You should still be able to preview the file manually though. If it doesn't use any server side stuff you can just open your HTML file in any browser. Otherwise just open the URL http://localhost/~/username/yourfile.html and it should come up.
     
  8. petec thread starter macrumors newbie

    Joined:
    Nov 5, 2007
    #8
    displaying web pages loacally

    Many thanks once agaiin...

    You were nearly there. The actual which I had to put into the url prefix box for the testing server is

    file://localhost/Userscomputername/Sites/MyWebsite name/


    Then clicking the Prevew/Browse in Browser works
    Alt + F12 however does NOT work - it deals with sound
     
  9. sahnert macrumors 6502

    Joined:
    Oct 20, 2003
    Location:
    Seattle
    #9
    Are you by chance using one of the new aluminum apple keyboards?
    The new set of multimedia buttons have new shortcuts assigned to them, one of which is to press option (alt) + f12 (volume up button) to get to the sound preference pane.

    I'm not sure of the best way to resolve keyboard shortcut conflicts, but you can try customizing your shortcuts in the Keyboard and Mouse preference pane.


     
  10. petec thread starter macrumors newbie

    Joined:
    Nov 5, 2007
    #10
    displaying web pages loacally

    Hi,

    Yes I am using one of the new aluminum apple keyboards, delivered with the iMac.

    Must say that I am not too happy with the low profile keys; I like the old ones better where the keys have a bit of travel because I tend to hit the keys quite hard when I type.

    I will have a look at changing shortcut options but am quite happy using the preview icon, which is just a smuch as a short cut as pressing two keys?
     

Share This Page