Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Displays won't stay asleep... help!

digitalhen

macrumors regular
Original poster
Jan 10, 2006
219
64
Hey,

If i set my displays to sleep in 1 minute (say, if I leave it on overnight, and want it to sleep pretty quickly), they both come back to life after a few minutes. Since they're bright, they absolutely illuminate the room and the S/O isn't too happy with me.

I have an Alu iMac 24", Dell 24", bluetooth mouse, external USB drive, USB keyboard. I tried switching off the bluetooth mouse, and it was no better.

Any idea what might be making the mac come back to life, or somewhere in a log that will tell me what caused it?

Thanks!
 

Silver-Fox

macrumors 65816
Jan 8, 2007
1,091
1
England
you could just turn the dell screen off, and turn the brightness down on the imac

but the screens normally wake when something is altered like mouse movement etc you might have a faulty connection some where keyboard maybe or your other screen connector
 
Comment

sulleric

macrumors newbie
Apr 23, 2008
2
0
I have had this same problem for a long time, and it's very frustrating. Unfortunately, silver-fox, iMac screen brightness doesn't actually turn off the screen on its lowest setting like it does on laptops. I don't have any idea what causes it, but I notice a very faint clicking sound coming from inside the computer after I sleep the display (ctrl+shift+eject). It usually gets turned on with one of these clicks, sometimes the first, sometimes the fourth or fifth.
I am so sick of my screen keeping me up at night...
 
Comment

digitalhen

macrumors regular
Original poster
Jan 10, 2006
219
64
I figured out the problem!! :)

Not sure if this is a bug, or a 'feature', but thought I would share in case any one else is having the same problem.

My displays have been randomly coming at all times of the day, they pop on, go to screensaver and then eventually go off again (the computer is obviously on to start with). This is a problem for two reasons, 1) it's a waste of energy, 2) it illuminates my bedroom at night rather like daylight.

It turns out the problem is caused by having Screen Sharing enabled, and the 5900 port (VNC) being exposed to the outside world through my router. While this allows me to remote connect from another Mac without having to set up SSH, it also allows anyone else to see.

The problem lies in the fact that the screen comes to life whenever ANYTHING connects to this port, be it another Mac, or a port scanner... before even authentication takes place. Tested this by trying to SSH to that port - bang, my monitors come to life.

Fixed it by removing the external port forward, and just using SSH into the Mac. Apple needs to stop waking up the screens until authentication has taken place.
 
Comment

rockstarjoe

macrumors 6502a
Jun 2, 2006
858
62
washington dc
I figured out the problem!! :)

Not sure if this is a bug, or a 'feature', but thought I would share in case any one else is having the same problem.

My displays have been randomly coming at all times of the day, they pop on, go to screensaver and then eventually go off again (the computer is obviously on to start with). This is a problem for two reasons, 1) it's a waste of energy, 2) it illuminates my bedroom at night rather like daylight.

It turns out the problem is caused by having Screen Sharing enabled, and the 5900 port (VNC) being exposed to the outside world through my router. While this allows me to remote connect from another Mac without having to set up SSH, it also allows anyone else to see.

The problem lies in the fact that the screen comes to life whenever ANYTHING connects to this port, be it another Mac, or a port scanner... before even authentication takes place. Tested this by trying to SSH to that port - bang, my monitors come to life.

Fixed it by removing the external port forward, and just using SSH into the Mac. Apple needs to stop waking up the screens until authentication has taken place.


Wow, this problem has been driving me mad the past few weeks. Thanks for the info. The weird thing is that this worked fine on Tiger. Something must have changed on Leopard to cause the screen to wake from port 5900 traffic...
 
Comment

Enuratique

macrumors 6502
Apr 28, 2008
276
0
I figured out the problem!! :)

Not sure if this is a bug, or a 'feature', but thought I would share in case any one else is having the same problem.

My displays have been randomly coming at all times of the day, they pop on, go to screensaver and then eventually go off again (the computer is obviously on to start with). This is a problem for two reasons, 1) it's a waste of energy, 2) it illuminates my bedroom at night rather like daylight.

It turns out the problem is caused by having Screen Sharing enabled, and the 5900 port (VNC) being exposed to the outside world through my router. While this allows me to remote connect from another Mac without having to set up SSH, it also allows anyone else to see.

The problem lies in the fact that the screen comes to life whenever ANYTHING connects to this port, be it another Mac, or a port scanner... before even authentication takes place. Tested this by trying to SSH to that port - bang, my monitors come to life.

Fixed it by removing the external port forward, and just using SSH into the Mac. Apple needs to stop waking up the screens until authentication has taken place.

SWEET JESUS! Thank you for this info!!!! I would have never thought that was it... I can't wait to go home and try this but I do have screen sharing turned on and I just thought that any time a CPU-intensive process activated, it would turn on the screen. But this makes a lot more sense. I agree - Apple should wake the screens only after authentication!
 
Comment

rockstarjoe

macrumors 6502a
Jun 2, 2006
858
62
washington dc
Anyone with a copy of Snow Leopard care to check and see if they fixed this? I switched routers to a Time Capsule and still have this problem if port 5900 is open.
 
Comment

Narrowfeather

macrumors newbie
Dec 25, 2010
1
0
Not the solution for me

I am running Snow Leopard 10.6.5 on a 27" Intel Core i7 iMac and experiencing the same problem, but I have never enabled screen sharing.
 
Comment

dav

macrumors 6502
Jun 29, 2004
493
10
I'm going to bump this old thread because this is the exact problem I am still experiencing. I have a 13" MBP running in clamshell with a 24" ACD. I usually leave my computer running and just sleep the display (control-shift-eject), but sometimes it would wake up in the night for no reason.

Figured Screen Sharing was the culprit and disabled that, and now it sleeps fine. Problem is, I like screen sharing and usually try to keep that running. I had my VNC port exposed to the internet, but closed that and it will woke from time to time. Is there any way to only make VNC accept connections from localhost so only I can wake it via SSH? Thoughts?
 
Comment

MBHockey

macrumors 68040
Oct 4, 2003
3,995
228
Connecticut
I figured out the problem!! :)

Not sure if this is a bug, or a 'feature', but thought I would share in case any one else is having the same problem.

My displays have been randomly coming at all times of the day, they pop on, go to screensaver and then eventually go off again (the computer is obviously on to start with). This is a problem for two reasons, 1) it's a waste of energy, 2) it illuminates my bedroom at night rather like daylight.

It turns out the problem is caused by having Screen Sharing enabled, and the 5900 port (VNC) being exposed to the outside world through my router. While this allows me to remote connect from another Mac without having to set up SSH, it also allows anyone else to see.

The problem lies in the fact that the screen comes to life whenever ANYTHING connects to this port, be it another Mac, or a port scanner... before even authentication takes place. Tested this by trying to SSH to that port - bang, my monitors come to life.

Fixed it by removing the external port forward, and just using SSH into the Mac. Apple needs to stop waking up the screens until authentication has taken place.

Not to necro this thread but I suspected this was the cause after my screen would randomly come on and I started looking through the logs; tons of failed connection attempts from Korean, German, etc. IPs on the VNC port. Maybe this wake-before-authentication is a problem only in Snow Leopard? I am hesitant to upgrade my old iMac to Lion but if it fixes this problem (along with unbearably slow TM backups) then maybe it's worth it.

In any case, thanks for your post!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.