Distorted Launchpad Icons

Discussion in 'OS X Yosemite (10.10)' started by JoshuaRystedt, Aug 4, 2014.

  1. JoshuaRystedt, Aug 4, 2014
    Last edited by a moderator: Aug 6, 2014

    JoshuaRystedt macrumors newbie

    Joined:
    Aug 4, 2014
    #1
    After using the Yosemite public beta (14A299l) for 10 days some of the icons in launchpad became distorted.

    - Every icon in folders is distorted.
    - Moving a distorted icon out of a folder does not resolve the issue - it remains distorted. Conversely, placing correct icons into a folder does not distort it.
    - An app icon on the dock may become distorted temporarily.

    [​IMG]

    [​IMG]

    This is definitely the oddest and most thoroughly annoying bug I have come across thus far.

    Have any other beta testers come across this bug?
    Any ideas on a user generated correction to this bug (rather than waiting and hoping for a fix in the next update)?

    [Picture removed as it contained serial number of computer]
     

    Attached Files:

  2. JoshuaRystedt thread starter macrumors newbie

    Joined:
    Aug 4, 2014
    #2
    Resetting Launchpad

    Resetting launchpad by deleting the .db file and killing dock no longer works in Yosemite.
    Does anyone know if launchpad now stores it's config file elsewhere?
    Has Apple migrated Launchpad away from the Dock application?

    I have a feeling that if I can reset Launchpad's settings I can get things looking normal again.
     
  3. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #3
    I'm thinking the .db file isn't as critically tied to Launchpad as it once was. I noticed trashing the file is one of the first steps people do for Launchpad issues.

    How about the suggestion that was mentioned in this thread for phantom/stuck downloads in Launchpad?

    In terminal, enter the following:
    Code:
    defaults write com.apple.dock ResetLaunchPad -bool true
    killall Dock
     
  4. JoshuaRystedt thread starter macrumors newbie

    Joined:
    Aug 4, 2014
    #4
    This Resolved My Issue

    @The19th

    This resolved my issue! Thank you greatly!

    [​IMG]
     

    Attached Files:

Share This Page