Distribution build errors

Discussion in 'iOS Programming' started by hoosierfan24, Aug 15, 2009.

  1. hoosierfan24 macrumors member

    Joined:
    Jul 31, 2009
    #1
    Hello I am finished with my ipod app and I am working on uploading it
    "the hardest part for me"

    and when I try to build my my app in the distribution configuration I get this error every time

    The iPod “ MY IPOD” doesn’t have the provisioning profile with which the application was signed.

    Please add the provisioning profile via the Organizer, or check the “Code Signing Identity” build setting.


    I have my distribution provisioning profile and it is selected for the code signing, but that code wont install on the ipod itself is that why it is not working ???
     
  2. ritsard macrumors regular

    ritsard

    Joined:
    Jun 18, 2009
    Location:
    SF Bay Area, CA
    #2
    I was having a similar problem and I saw in a post somewhere to just restart Xcode...give that a try.
     
  3. admanimal macrumors 68040

    Joined:
    Apr 22, 2005
    #3
    Is the error when it is building the application or are you doing a Build & Go and the error is when it tries to run the application (which you can't do with a distribution build).
     
  4. MacToddB macrumors 6502a

    MacToddB

    Joined:
    Aug 21, 2007
    Location:
    Rochester, NY
    #4
    Right. The iPod (or iPhone) error tells me you're doing Build and Go, i.e. install on a device. Not allowed for Distribution. If you Build and Go under Development and it works on your device, then change to Distribution, Build (not Build and Go), and, in Finder, Compress the .app file, and upload in iTunesConnect.
     
  5. hoosierfan24 thread starter macrumors member

    Joined:
    Jul 31, 2009
    #5
    Yes it is when I get the build and go i get the error I will try the just build option and then let you know how it goes
     

Share This Page