Distribution Cert and Profile nigthmare

Discussion in 'iOS Programming' started by Craigy, Nov 8, 2008.

  1. Craigy macrumors 6502

    Jan 14, 2003
    New Zealand

    Our first app is ready to go - the meta data and images are all on the portal but I'll be dammed if I can get the distribution cert and profile to show in xCode.

    In my Keychain - Under keys I have a public and private key. Under private I have my iPhone Developer: xxx key but no distribution key.

    However if I look in Certificates I can see the developer and distribution certs both linked to by private key.

    So - Firstly I'm not sure if everything is as it should be in my keychain.

    Anyway - I've created a distribution profile and dragged it to Xcode but I can't select it in the Target build info or the project build info.

    I've looked in library/mobiledevice/provisioningprofiles and there is a new file there with a really odd filename:

    To sum up - I'm totally lost - had no problems with my development cert and provision but this has completely foxed me..

    I'm desperate to get my app out - any help / advice would be really appreciated!

  2. narut macrumors newbie


    Nov 2, 2008
    Have you tried drag the file to ~/Libraly/MobileDevices/ProvisioningProfiles manually?

    And you have to set your Active Configuration in Xcode to Distribution before the Distribution Provisioning file will show up in Target Info.

    Hope this help :)
  3. Craigy thread starter macrumors 6502

    Jan 14, 2003
    New Zealand
    Thanks! - Did that - deleted all my certs and profiles and started again from scratch - worked then - to be replaced by another issue!

    I now can't seem to get either Application Loader or the web upload on iTunes Connect to work.

    Application loader stays on Verifying Application Checksums for about 1.20 and then times out.

    The web upload displays "Cannot Process Request - An error has Occurred Processing Your Request"

    My zipped binary is 106mb so within the limits.

    To add insult to injury - I thought I'd download Application Loader again and cant get the DMG file to mount after downloading with either Safari or Firefox!:mad:

    Tried last night and this morning with the same results - fired off a email to Apple but last time I did that I never got a reply.... Feeling sad now:(

    Any advice would be greatly appreciated.

    Attached Files:

Share This Page