DIY Fusion Drive with Boot Camp on SSD problem! Help!!

Discussion in 'iMac' started by andycho7, Jan 26, 2014.

  1. andycho7 macrumors member

    Joined:
    Dec 2, 2013
    #1
    Hello all, I believe this is my first post here. I have done some intensive search about this particular topic, but haven't found a luck yet.

    So, last week I opened up my 27 inch iMac(mid 2011) and installed a 250GB Samsung 840EVO SSD under the optical drive bay(so I now have 3 drives total). Plugged in the USB thumb drive that contains Mavericks restore, did the whole Fusion drive setup. So! Only difference here is that normally, people would just fuse the entire HD and SSD without splitting the capacity/partition of neither drives, but what I did was I split the SSD into 2 partition making it 60 GB and 190GB each. Purpose was so that I can install the Windows into the 60GB partition and 190GB partition for the Fusion Drive.

    Mavericks installation went smooth, no problem. After the installation, I headed over to Boot Camp Assistant to install Windows on my 60GB partition on SSD. Then I started running into some problems...

    1. Although I have a separate partition dedicated just for the Windows 7, Boot Camp Assistant is telling me to create a new partition for the new Boot Camp Assistant. I'm assuming that this is happening because I didn't split the original drive, but the second SSD drive.
    So I was thinking, well if I can just split the Fusion Drive here and just select my 60GB SSD partition during the Windows installation, I guess it should work! So I did. Then...

    2. Windows was successfully installed on SSD, and everything went as I hoped for. Installed Boot Camp drive, etc etc.... I thought everything was good UNTIL!

    On Windows, I launched the Boot Camp control panel program so that I can boot on Mac OS X for my next boot-up. Changed the setting, then restarted the computer. I got into Mac OS X, did some stuff, then I tried to get back on the Windows... but I don't see it anywhere anymore.

    I still see my BOOTCAMP partition on my list of hard drive on Mac's side. But if I go to system preference on mac, and try to select a start up disk, BOOTCAMP is not there anymore. I tried the holding alt while boot up, but I still didn't see it. I also tried the rEFIt, but it seems like that program is having an issue with Mavericks or something.. I just can't get it to work. So the next thing I tried was to use the Parallels. Thankfully, Parallels DID initialize the Windows partition. HOWEVER, since it was first time running Parallels on that Bootcamp partition, it did some initial setup and installation or something, who knows what... then later it asked me to log in to the Windows partition by restarting the computer or something... which I can't at this point. So.......

    3. I found this program called "BootChamp". Basically it's a simple program that lets you boot into your Bootcamp partition with just couple clicks. So I did try that and got much further than ever before... BUT this time, it gave me that classic "No boot device found" error.


    So I've been searching the internet all over the weekend, still haven't found a working solution for this... Anyone have any tips for me? Help!!!
     
  2. andycho7 thread starter macrumors member

    Joined:
    Dec 2, 2013
  3. GiLLER macrumors newbie

    Joined:
    Apr 1, 2011
    Location:
    Copenhagen, Denmark
    #3
  4. andycho7 thread starter macrumors member

    Joined:
    Dec 2, 2013
    #4
    I really appreciate your response. It's ironic because while I was doing some search over last weekend, someone mentioned how Repair Disk in disk utility actually fixed their issue, but it sure didn't fix mine and looks like that may be part of the cause. I'll give this a try.
     
  5. andycho7 thread starter macrumors member

    Joined:
    Dec 2, 2013
    #5
    Ok, as obvious and strange it may sound I just popped in the Windows 7 install DVD and just reinstalled the whole windows after deleting the portion of that SSD partition, then just completed a reinstall.

    Only thing different this time, is that I saw some post online someone saying that disabling the Paragon software(something like Paragon NTFS?? so you can write NTFS on mac) actually did the trick. Before disabling the Paragon, it never showed my Bootcamp partition as an available bootable device but now it shows clearly and will boot into Windows successfully. At least for now..
     

Share This Page