DLink di-624 woes

Discussion in 'Mac Basics and Help' started by Sapiens, Nov 23, 2005.

  1. Sapiens macrumors newbie

    Sep 16, 2005

    My di-624 and SBC modem both have the same IP address,, and I believe this is causing some problems (the router log keeps mentioning "Smurf attack detected") and the router keeps freezing up. I tried to change the router LAN IP address, but then it won't let me connect to the internet.

    I'm not very knowledgeable when it comes to networking, so I'd appreciate any insight. :confused:

    If it makes any difference, I'm using a g5 pm with airport 4.2, but it does this even with ethernet. Thanks.

    Update: Nevermind, for now. I tried changing the IP address again, and this time it worked. I'll see if it improves my prognosis.
  2. Sapiens thread starter macrumors newbie

    Sep 16, 2005
    Ok, I knew I'd be back. The internet connection works fine via ethernet with the router's new LAN IP address, but I can't get connected using airport. It shows that it's connected to my network, but won't get on the internet.

    Is there something I have to configure on my network card to recognize the router's changed IP address? Many thanks.
  3. Sapiens thread starter macrumors newbie

    Sep 16, 2005
    Please help me get this working

    I'm getting very confused and frustrated by my router's behavior. The problem I was having before was that, while being connected to my network, I could not connect to the internet. For it to normally connect, configurations should look like this:
    (using DHCP)
    IP address:
    Subnet mask: blah blah blah
    BUT the network configuration window said that Airport had a self configured IP address that might not connect to the internet. The IP address was different, the subnet was the same, and there was no address for the router.

    I had heard that WPA with this router was problematic on a Mac, so I switched back to WEP and restarted everything. I was able to connect. The configurations all looked as they should. But when I try to switch to a different password key for WEP, the same thing happens--self configured IP address, no router address listed, no internet connection. I have to switch back to the first password key and then all is well.

    Is there something I can do to allow multiple password keys for WEP, or (if I can dream) even use the WPA encryption? Why does the airport keep giving itself an IP address that won't connect?

Share This Page