DLSDilemma -- DVD no longer recognized

Discussion in 'PowerPC Macs' started by ziggy29, Feb 26, 2018.

  1. ziggy29, Feb 26, 2018
    Last edited: Feb 26, 2018

    ziggy29 macrumors 6502

    Joined:
    Oct 29, 2014
    Location:
    Oregon North Coast
    #1
    I obtained a sweet DLSD a couple weeks ago. I performed an HDD to SSD swap by using a 250 GB mSATA drive with IDE adapter to replace the spinner, and as is my usual, created two partitions, one for Leopard and one for Tiger/Classic. Works great, throughput has gone from about 35 MB/sec to about 83 MB/sec. It is a much more pleasant user experience.

    But something strange happened in the swap -- the SuperDrive is no longer recognized. It IS getting power -- when you put a CD in there it spins up but does nothing, and certainly won't mount -- but the computer can not recognize the drive and apparently can not communicate with it. It was working before the swap.

    I've double checked and triple checked all the connections from ribbon cables to the board; they all look well connected and solid. But System Profiler says "no burning device" was found. I've put in a different, known-good compatible DVD drive and it has the same issue.

    So this is a shot in the dark: Has anyone seen anything like this in a PBG4, particularly a 17" model? I don't see how a simple swap from HDD to SSD could disable the DVD, so I haven't tried it swapping it out again. In any event, I use the CD/DVD so rarely now that I'd sooner leave the SSD in there anyway.
     
  2. Cox Orange macrumors 68000

    Joined:
    Jan 1, 2010
    #2
    I found a thread where someone had a similar (though not exactly the same, I guess) problem. He ended up getting a new HDD-cable and then the combination of HDD+DVD did work again. However it seems someone had installed a HDD-cable from a low-res Powerbook before the person got the machine. I am not sure, if his DVD-drive worked in the first place... have a look https://macosx.com/threads/powerbook-g4-cd-dvd-drive-not-recognized.293906/

    Maybe you can find another suitable thread with different search terms , if you search google again, which I know you probably already did, but sometimes one just needs to find the right search terms and not give up early.
     
  3. eyoungren macrumors Core

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
    #3
    I had an iBook G4 once where the hard drive worked fine until things heated up and then it'd freeze during installing OS X.

    Turns out that the person who gave it to me had been a little too aggressive in pulling out the ribbon cable for the hard drive. The cable was fine but he had slightly ripped the actual connector off the logicboard. I had a similar experience with a garbage A1013 I had once where the connector for the keyboard ribbon cable had actually come off. That was a problem because I couldn't get the damn thing to turn on half the time.

    Anyway, my point is that if Cox Orange's suggestion is not the solution you might take a look to see if any of the actual connectors on the board for the optical drive have come up.

    About all I can think off.

    Weird problem.
     
  4. Cox Orange macrumors 68000

    Joined:
    Jan 1, 2010
    #4
    I am thinking now, maybe the person in my link had the same problem, though he didn't know. Maybe, when installing the new cable he pressed the connector to the board again and it got better contact with the board again - a very loose contact though. Maybe, he got somewhat like a loose connection that sometimes gets contact and sometimes doesn't...
     
  5. AphoticD macrumors 68000

    AphoticD

    Joined:
    Feb 17, 2017
    Location:
    Australia
    #5
    If you are going to glue it back down, be mindful that superglue is typically conductive, so go light on by using a toothpick or something fine to apply. Otherwise, a blob of blutack or card to apply some pressure from above might just solve it.
     
  6. ziggy29 thread starter macrumors 6502

    Joined:
    Oct 29, 2014
    Location:
    Oregon North Coast
    #6
    Possible clue here. I just remembered that when I had it open to install the SSD, I found a loose plastic piece on my work area that I didn't recognize. Maybe it came out while I had the PB open and facing down? I didn't think much of it at the time, but I managed to find the piece in question on my desk and here it is. Does this look familiar to anyone? And might it be part of the problem? IMG_20180304_074931.jpg
     

Share This Page

5 February 26, 2018