dmg files will not mount - HELP!!!

Discussion in 'macOS' started by rayna0215, Oct 1, 2007.

  1. rayna0215 macrumors newbie

    Joined:
    Sep 30, 2007
    #1
    Hi. I have a Powerbook G4 with 10.4.10 installed that I bought from a friend who upgraded. Since I've gotten it, I have not been able to mount any dmg files. Everytime I get errors that say "mounting failure" and "device not configured". Everything was working perfectly before switching the users.

    I have tried repairing permissions and the disk and deleting cache/ kernals, but so far nothing has worked. I would do a clean install, but I only have the disk for 10.4, and would thus lose the current operating system. I am in Istanbul and there is no Apple support here and very, very few Mac owners. I've also looked online for another program to open dmg files, but these programs are all in dmg format, which of course I can't open. Stuffit is also not working. It says it is missing the Stuffit Engine. I have recently added Unarchiver to open other formats, however. Can anyone help me, PLEASE?
     
  2. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #2
  3. rayna0215 thread starter macrumors newbie

    Joined:
    Sep 30, 2007
    #3
    I double-checked, but Disk Image Mounter is set as the default. I tried the fix in the link and after a couple minutes, I still get the "device not configured" error. So, I still am completely unable to open dmg files, but thanks a lot for trying to help.
     
  4. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #4
    Did you create a new user after you got it?

    It may be the permissions are set differently due to the sellers account still on the Mac.

    Hopefully you got the Install disks that come with a Mac ? If so just re-install the O/S
     
  5. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #5
    I had a similar issue a while back. I tracked it through the console logs to a duplicate kext being installed by something (my suspicions were with Parallels but I could never prove it). Unfortunately I could not locate the duplicate kext so I was only able to solve it via a full re-install. Once done I reinstalled all the software I had installed (including Parallels) without the issue returning...
     
  6. rayna0215 thread starter macrumors newbie

    Joined:
    Sep 30, 2007
    #6
    I have 10.4.10 installed now, but only have the install disk for 10.4. I don't want to lose the current OS, if at all possible, so I have been avoiding doing a re-install with the 10.4 install disk. If there's not another solution, is it possible to re-install the older OS without losing the newer OS?
    This seems to be a problem for quite a few people. My parents actually have the same problem with their PowerBook back in the U.S. and I have seen numerous similar posts around, unfortunately without a solution.
     
  7. rayna0215 thread starter macrumors newbie

    Joined:
    Sep 30, 2007
    #7
    I finally got frustrated and re-installed the OS. Then I found out that everything after 10.4 is available as online software updates. Anyway, everything is working great now. Thanks for you help everyone!
     
  8. macjack1 macrumors regular

    macjack1

    Joined:
    Oct 3, 2007
    Location:
    The Big Apple
    #8
    Glad you're up and running :)

    If this comes up again check in Safari menu >> Preferences >> General: "Save downloaded files to Desktop", be sure you have your desktop or correct folder chosen. It is easy for it still to be pointed to an old desktop or the desktop of a previous owner.

    -mj
     

Share This Page