.DMG is Mounted but Does Not Exist??

Discussion in 'OS X Yosemite (10.10)' started by TuckerFatal, May 18, 2015.

  1. TuckerFatal macrumors newbie

    Joined:
    Mar 18, 2014
    #1
    Hey all,

    I opened Disk Utility just earlier to format a USB drive, and noticed that a disk image called 'Aviator' was mounted on my computer. This is an application that I installed quite some time ago, and have since deleted. I tried to click Eject but I got the following error message:

    "The disk “com.whitehatsec.aviator.dmg” could not be unmounted.
    Make sure that all applications and files are closed on this disk."

    Basically it won't let me unmount the disk image because it thinks the program or some component of it is still running, but obviously it isn't. I checked Activity Monitor to be sure, and there is nothing by WhiteHat or Aviator running on my computer. I found the .dmg file in Finder and tried to trash it, but when I went to empty the trash can, it told me the action could not be completed because the file was in use.

    This is one of the weirdest things I've ever seen on my Mac, and I have no idea how to fix it. Maybe it doesn't affect anything, but it's confusing and I'd like to remove it. Anyone have any ideas? Would using 'sudo' in the Terminal to manually remove the .dmg solve the problem? I'm hesitant to do that because then it might be stuck that way forever.

    If anyone has any thoughts, they are much appreciated. Thank you!!
     
  2. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #2
    Try logging out and logging back in to your account. If that does not work, reboot the computer.
     

Share This Page