dmMediaConverter v1.8.0 - FFmpeg GUI [Mac/Linux/Windows]

Discussion in 'Mac Apps and Mac App Store' started by mdalacu, Sep 22, 2014.

  1. mdalacu, Sep 22, 2014
    Last edited: Sep 18, 2015

    mdalacu macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
    #1
    [​IMG]
    dmMediaConverter is a crossplatform FFmpeg frontend (GUI) exposing some of its features. It is intended to be simple and easy to use but also to be able to achieve complex tasks. I have inspired myself from a lot of media converters like Handbrake, WinFF and MkvMergeGui. One feature was lacking from most of them, video stream copy (pass-through), that made me build this.

    Hi, i am writing here to see if there is enough interest from you to build a native mac application. In the mean time, please install WineBottler (or wine for mac) and then download the win32 version of the app from my site and run it.

    http://dmsimpleapps.blogspot.ro/2014/04/dmmediaconverter.html

    So, does it run well for you? Do you need a native app?
    i don't own any mac devices so it will be a little tricky for me.
    Also, any kind of feedback it is kindly appreciated.

    Thank you and i hope that i didn't post in the wrong section :p

    UPDATE: Now a NATIVE version is available on Amazon for 5$.
    http://www.amazon.com/gp/product/B0158GZ136
     
  2. mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
  3. mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
    #3
    New, big release: v1.5.0!
    Changelog:
    - Parallel jobs - you can run multiple jobs in the same time
    - Initial job progress implementation
    - Split UI improvements
    - Running under WINE is more robust now (Mac Os)
    - Internal code rework
    - Updated FFmpeg binary with latest version

    I hope you like it and please provide feedback!
     
  4. mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
    #4
    Version 1.6.0 is up! :)

    Minor release:
    - Added checkup for not overwriting the source file.
    - You can assign dmMediaConverter to open media files. (ex. Right clik on file and "Open with..." dmMediaConverter's executable). You can use it like media info.
    - Now bitrate will be shown in kbit/s for better readability.
    - Small UI fixes
    - Updated FFMpeg binary with latest version

    http://dmsimpleapps.blogspot.ro/2014/04/dmmediaconverter.html
     
  5. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #5
    First I saw this....must have missed the initial announcement. I don't consider running this under Wine on a Mac as being truly "cross-platform"....I'd love to see a native Mac app. But since I did miss this initially, I've bought iFFmpeg.
     
  6. mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
    #6
    http://dmsimpleapps.blogspot.ro/2014/04/dmmediaconverter.html
    Version 1.7.0 is up ;)

    - Burn text based subtitles (not yet picture based).
    - Now you can manually specify additional FFMpeg filters (More) for audio and video streams.
    - On linux it removes automatically "'" from metadata. Workaround for MKVToolNix generated files.
    - Added option for auto add subtitle file (only *.srt for now).
    - Small UI fixes and bugfixing
    - Updated FFMpeg binary with latest version
     
  7. mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
    #7
  8. mdalacu, Apr 12, 2017
    Last edited: Apr 12, 2017

    mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
  9. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #9
    You need to update the following info on Amazon:

    System Requirements
    Platform: Mac OS X 10.6 Snow Leopard, Mac OS X 10.8 Mountain Lion, Mac OS X 10.10 Yosemite, Mac OS X 10.9 Mavericks, Mac OS X 10.7 Lion

    I see no mention of 10.11 or 10.12
     
  10. mdalacu thread starter macrumors newbie

    mdalacu

    Joined:
    Sep 22, 2014
    Location:
    Bucharest, Romania
    #10
    @fhall1 Hi, thanks for the heads up! I have updated the product description, it will take an while until will be visible on Amazon...
    The app works on 10.12, i have tested it.
    Thanks again.
     

Share This Page