DND - unwanted calls

Tech198

macrumors G5
Original poster
Mar 21, 2011
14,095
1,677
Australia, Perth
I started using Do Not Disturb on my iPhone for block unwanted calls NOT on my contact list..

However, i quickly found its kinda "kludgy" ...or i haven't set it up right. Ideally, i want only calls on my contact list to come in, and block all others..

However, it seems like you can either:

- Set DND to "Allow calls from" "Contacts" Group
- Set DND to "Allow calls from" Favorites.

The 1st would work, *but* with the cavaet the same person must ring back within 3 minutes, otherwise they'll get blocked

or.... 2nd option to allow from Favorites, which would mean i must add each on my contacts to the phone.app, I have a large section of contacts.

Turning off 'Repeated calls" is ignores them anyway.
 

Attachments


NoBoMac

Moderator
Staff member
Jul 1, 2014
2,533
931
As set up in image, should be working without caller having to call again within three minutes.

I'd take a close look at your contacts. Might be something off re: field the number is in and or format of the number (thinking if is/was synched from some other service and something got messed up in the process re: mapping of fields; incoming caller id is one format for number, stored differently in contact).

ADD: DnD has always worked correctly for me.
ADD2: since you have a Mac, and if using iCloud to sync contacts, might try adding a subset of your current contacts to a new group, call it something like "DnD Allow". Then on the phone, change "All Contacts" to the "DnD Allow" group, and see if that helps/works. If so, then might be a bug with using "All Contacts" and now have a workaround to having to add everyone to Favorites.
 
Last edited:

Tech198

macrumors G5
Original poster
Mar 21, 2011
14,095
1,677
Australia, Perth
format for phone no field is area code, + number

I don't use iCloud to sync anything.. so that's not a problem there. The numbers were typed into contact list manually, and have double checked format ....
 

George Knighton

macrumors 65816
Oct 13, 2010
1,305
290
... and have double checked format ....
You are outside North America so I am not sure what your Caller ID looks like.

Where I normally live, work and travel most of the time, I have noticed a couple of different ways that Caller ID will identify an incoming number. Whichever way the call is being identified must be exactly the way the number is listed in your Contacts.

Once I discovered this back in the jail breaking days, I started being sure that a contact is always listed as "1 (111) 111-1111" and also "(111) 111-1111" so that I got 100% correct usage out of the application that we were using in the jail breaking days before iOS had the DND function.

I cannot offer any proof that making sure the format in your Contacts and Caller ID are the same will help; however, my DND settings work perfectly and I do not have the symptoms you have.