DNS issue with 10.6

Discussion in 'Mac OS X Server, Xserve, and Networking' started by akaash1087, Sep 27, 2010.

  1. akaash1087 macrumors newbie

    Joined:
    Jul 7, 2010
    #1
    I have an issue with Mac OS X 10.6 DNS configuration i.e. DNS can be only made active by using the System preferences configuration via GUI.

    The System preferences configuration has 2 options for Ipv6 configuration – Static and Automatic

    Automatic refers to getting the details via Router advertizing , even in this case the dns should be set manually.

    So using the ISC script , the DNS gets set but it doesn’t work when we try to use it.

    We also tried to use the Networksetup command line tool which automatically fills in the system preferences
    From the back end (from the command line)even that is not working properly .

    Using Networksetup to fill the ipv6 address details always shows errors.

    any suggestions ??..
     
  2. assembled macrumors regular

    Joined:
    Jan 12, 2009
    Location:
    London
    #2
    Are you actively using IPv6 ?

    Do you have a IPv6 DHCP server, firewall and internet connection ?

    If you don;t, just disable it and use IPv4
     
  3. akaash1087 thread starter macrumors newbie

    Joined:
    Jul 7, 2010
    #3
    made a bit of progress

    I think configd is causing the trouble.I cant understand the behavior of congifd .When I make some changes to the Network preferences file it gets saved in /Library/Preferences/SystemConfiguration/preferences.plist. so,I made 2 different configurations on Network preferences Pane


    1. IPv4 AND IPV6 off (in this case ping6 does not work)

    2.IPv4 OFF and IPV6 "MANUAL" (in this case ping6 works)

    In both cases the settings got saved in the preference.plist and I took a backup of both the files on the Desktop and created a patch.

    In the first configuration,ping6 does not work.Then, I manually changed the preferences.plist file by applying the patch ,I noticed 2 things

    1. Settings gets updated in Network Preferences Pane.
    2.ping6 DOES NOT work.This is my worry.If the same settings are applied from Network preferences Pane ping6 works,
    but If I try to patch it,it doesnt work.Also,after patching the preference.plist file, If I reboot, then ping6 starts to work.Seems like configd reads the new configuration only on reboot.

    I have read that configd reads from preference.plist file and recognises whenever there is a change in it and
    implements the new settings.
    What is happening here????Is the configd not reading the new configuration when the preference.plist changes???Does it read the new config only on reboot?? how do I make it read the new configuartion??
    I tried to stop and then re-start configd...didnt work out..configd still doesnt read the new configuration
     

Share This Page