DNS/Linux Drive: how to mount it

Discussion in 'macOS' started by sTcA, Aug 22, 2011.

  1. sTcA macrumors newbie

    Joined:
    Mar 28, 2011
    #1
    Good morning,

    My D-Link DNS 323 is dead (following to electrical problem). It had 2 drives in Raid 1. One of the two disks is dead too. I then tried to connect the remaining drive with a SATA cable directly to my MacPro (OS X 10.6) but i cannot mount it.

    Does anybody know how I can read the files on that drive from my Mac?
    Thanks,
    s
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    You probably need another dlink to be able to read those files. It is possible the drives are linux format. If so, you should be able to read them in os x. Google for ext3 os x to see how to read linux partitions in os x.
     
  3. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #3
    DLink has a support forum you might get more info. Looks like they use EXT2 ( a linux format).
     
  4. speacock macrumors member

    Joined:
    Jul 26, 2011
    Location:
    UK
    #4
    I'd use UFS explorer

    You can get third party IFS modules to mount foreign filesystems but I've never tried them.

    If I ever need to recover content from a disk that isn't physicall dead I use UFS explorer - http://www.ufsexplorer.com

    It's not free but it is useful and it does all kinds of recovery tasks too like searching deleted filespace, fixing broken filesystem tables and so on.

    I think it supports EXT2 & 3, HFS, NTFS, FAT, XFS and a few others, but you want to check it'll work with your disk before buying. You can download an eval version which wil let you mount the FS but will only allow you to copy small files off and only a few at a time, but at least that'll prove whether it works for you.
     
  5. Clodey macrumors member

    Joined:
    Aug 24, 2011
    Location:
    Wales, UK
    #5
    If you haven't yet found a solution this might help. I have a Dlink router with a built in hard drive but it is formatted in ext3 which finder does not like - it says I do not have permission to open the folder and all sorts of rubbish. So I downloaded muCommander as an alternative to finder. By using this I can access the hard drive :)
     
  6. sTcA thread starter macrumors newbie

    Joined:
    Mar 28, 2011
    #6
    Thanks everybody, I've finally purchased a new DNS (in the meantime the model changed to 320) and able to read the one disk left of my raid1 set. I also had the opportunity to test the D-Link technical support here in France and it is just useless... Pity I had to buy another of their products to solve my problem (it has probably been cheaper than send the disk to the lab to get the data out).
     

Share This Page