dns not working

Discussion in 'Mac OS X Server, Xserve, and Networking' started by akaash1087, Sep 24, 2010.

  1. akaash1087 macrumors newbie

    Joined:
    Jul 7, 2010
    #1
    I have created a v6 over v4 tunnel in Mac osx 10.6. I use a command
    sudo networksetup -setdnsservers 2011::1 to set up DNS server.After this I find that the dns addr (2011::1) appears in the network preferences pane.But I cant ping any address,
    Also,/etc/resolv.conf is empty.

    I tried like anything but it doesnt work.Has the networksetup command changed in 10.6? It worked in Mac 10.5.I have checked the man page.I dont see any change. Or is some extra step required along with networksetup command ?? is it that the dns address gets written at some other place??

    how do I get my ping to work?any suggestions...??
     
  2. foidulus macrumors 6502a

    Joined:
    Jan 15, 2007
    #2
    Have you tried dig(though if nothing is in your resolv.conf I doubt dig would work)

    Also keep in mind that as of OS X 10.6 99% of Apple's stuff doesn't use resolv.conf anymore, it all uses mdns. resolv.conf is simply there for backwards compatibility with unix tools.
     

Share This Page