DNS OpenDNS Charter Mac OSX DNS Not Taking

Discussion in 'macOS' started by mrpeepers, Jul 28, 2008.

  1. mrpeepers macrumors regular

    Joined:
    Aug 14, 2007
    #1
    So I'm trying to configure my Mac for use with OpenDNS since I think Charter's DNS servers are slowing me down.

    I unplug my router.
    Go to System Prefs
    Network
    Advanced
    DNS tab
    and there's nothing there (there is when I am connected but it's grayed out)
    so I add 208.67.222.222 & 208.67.220.220, apply, etc...
    Plug in the router and Charter's DNS servers are back in there in addition to the OpenDNS ones at the bottom.

    Why? Why is my Mac automatically setting the DNS?
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    It's not. Your modem/router is providing them to the computer, thus the grayed out numbers. You would have to change the settings on the modem/router to remove those.

    jW
     
  3. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #3
    To use opendns, it's best to put the opendns ip addresses in your router settings.
     
  4. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #4
    Go here and pick your router for instructions: https://www.opendns.com/start

    You obviously have a router that receives Charter's DNS information, which in turn is sent to all network devices via the router. So, you'll need to change the DNS servers manually at the router.
     

Share This Page