DNS problem

Discussion in 'macOS' started by bllgrn, Mar 18, 2011.

  1. bllgrn macrumors newbie

    Mar 17, 2011
    I am running 10.6.6 and I am having problems resolving DNS within any web browser, I have tried Firefox, Chrome, and Safari. From Terminal I can resolve DNS just fine.

    I have tried using my home ISP's, work ISP's, Level3, and OpenDNS servers, none have worked.

    I have tried renaming my Network Location, I have renamed various .plist files under /Library/Preferences/SystemConfiguration/ including Preferences and NetworkInterfaces.

    I also run a couple Parallels VM's they are not having any problems resolving DNS.

    I'm running out of ideas, here, any other suggestions?
  2. tcador macrumors regular

    Jan 16, 2008
    when did the problems start? Any changes made to your computer before/after?
  3. bllgrn thread starter macrumors newbie

    Mar 17, 2011
    Negative, no changes made recently. Problem occurred two days ago nothing new was installed on around the time it started.
  4. baummer macrumors 6502a

    Jan 18, 2005
    Southern California
    Do you have any third party firewall applications running?
  5. bllgrn thread starter macrumors newbie

    Mar 17, 2011
    No firewall.
  6. jimsiff macrumors newbie

    Mar 10, 2011
    Portland, Or
    Are you using nslookup from Terminal? If so, nslookup doesn't use the gethostbyname() function, so it's not always a reliable indicator of how DNS is being handled for other applications.

    Does dig work? Try 'dig @ $hostname' where $hostname is the host you want to query for. is OpenDNS.

    What does /etc/resolv.conf show?

    Try doing a tcpdump to see if your DNS queries and responses are getting out and back to you.

    1) Use ifconfig to find your active interface, usually en0 or en1 for wired/wireless.
    2) Run tcpdump -i $interface host from a Terminal.
    3) Run dig @ www.google.com from another terminal.

    You should see a DNS query and response, looking similar to this:

    16:03:34.495967 IP > resolver1.opendns.com.domain: 10555+ A? www.google.com. (32)
    16:03:34.560531 IP resolver1.opendns.com.domain > 10555 6/0/0 CNAME www.l.google.com., A, A, A, A, A (132)

    Hope this helps...
  7. bllgrn thread starter macrumors newbie

    Mar 17, 2011
    I am definitely resolving DNS in Terminal, but browsers are still thumbing their nose at me.

    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on en1, link-type EN10MB (Ethernet), capture size 65535 bytes

    09:43:47.811704 IP > 9097+ A? google.com. (28)
    09:43:47.854890 IP > 9097 5/0/0 A, A, A, A, A (108)
  8. Detrius macrumors 68000

    Sep 10, 2008
    Asheville, NC
  9. benbur macrumors newbie

    Mar 20, 2011
    Similar issue!

    I have been having a similar issue, except only under one domain. Every other domain that I've tried works just fine. It's being resolved in terminal and works normally on every other machine on my local network. If I take my laptop to a different network, it still doesn't work. See my post on the Apple forums for more details: http://discussions.apple.com/thread.jspa?threadID=2789450&tstart=0.

    This sounds to me like the same problem as the OP's... For now I'm able to connect to hosts via their IP addresses, but it's rather inconvenient.
  10. bllgrn thread starter macrumors newbie

    Mar 17, 2011
    Yes, numerous times.

Share This Page