DNS stopped working

Discussion in 'Mac OS X Server, Xserve, and Networking' started by kc2kth, Jun 6, 2010.

  1. kc2kth macrumors member

    Aug 27, 2009
    This isn't a Server issue, but a networking issue within Snow Leopard. Hope I'm in the right place. Just got my mbp back from the Apple store - in for logic board replacement, no other changes. DNS seems to have stopped working - I can access my gateway, I can ping my provider's DNS servers, DNS addresses are assigned via DHCP, and these are working on a second Macbook on the same WiFi and wired networks.

    All DNS queries fail - dig tells me no servers can be contacted. If I dig @server_ip for my provider's DNS server, I get the correct list of roots. If I "sudo dig" I also get everything back correctly against my provider's DNS server. nslookup seems to behave the same - no servers unless I run under sudo.

    Comparing settings between my two machines, all looks normal. DNS server addresses and network settings match. I've bounced the mbp a few times, played with mDNSResponder a bit, but didn't find anything useful. I tried creating a new profile (another admin profile, same as my "standard" account on the mbp), and the behavior is the same.

    Any ideas why all of my dns queries fail unless I execute them under sudo?

  2. Alrescha macrumors 68020

    Jan 1, 2008
    You might verify that /etc/resolv.conf is a symlink to /var/run/resolv.conf and that the file is world-readable.

  3. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
    On that note, it would be best to repair permissions in Disk Utility to ensure all system files are accessible.
  4. kc2kth thread starter macrumors member

    Aug 27, 2009
    Great call, should have thought of that myself! I've seen that listed as a fix for a lot of issues many times, never had to do it though. Makes sense since the machine wouldn't boot that permissions could have been hosed. Thanks for the pointer!

    And I did check the resolv.conf file permissions and that it was a symlink first - all looked good there, so the issue must have been elsewhere.

Share This Page