Do I Have A Virus?

Discussion in 'macOS' started by Yellowstone2012, Apr 1, 2011.

  1. Yellowstone2012 macrumors regular

    Joined:
    Feb 3, 2011
    #1
    I'm pretty sure my Mac is infected, as some strange things have been going on.

    1) My "view options" were originally set to snap to grid. Now they aren't; I have not changed the settings what so ever.

    2) My password (!) changed. I tried to install something the other day using my current password, and the installer showed the "wrong password" message. I did NOT change the password.

    3) I previously had flash INSTALLED, yet I load up Firefox today, and what happens? I get "Install Missing Plugins to view content on this page". I did not uninstall flash (I would not; YouTube surfer).


    Is it a Virus or just my 3 year old Mac acting up. (I use it A LOT)

    Also, I'm currently triple scanning with ClamXav. (which is a neat piece of software, BTW!)

    Thanks for the replies.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    There has never been a virus in the wild that runs on Mac OS X. The handful of trojans that exist can be easily avoided with some education and common sense and care in what software you install:

    View options... where, exactly?
    Make sure your caps lock key isn't on.
    Perhaps you need to install a newer version.
     
  3. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #3
  4. munkery macrumors 68020

    munkery

    Joined:
    Dec 18, 2006
    #4
    This other thread has good information about viruses on your mac.
     
  5. Yellowstone2012 thread starter macrumors regular

    Joined:
    Feb 3, 2011
    #5
    Yep, I made sure my CAPS lock key wasn't on; as I used my older password to install the software.

    Yep, I need to install a new version.


    I have 10.6.0 and "iMac 8,1"

    No, no other people / animals have access to my Mac.

    Thanks.
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    You can reset your password via these means: http://support.apple.com/kb/ht1274

    You also should run Software Update to make sure you run the latest version of Mac OS X.
     
  7. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #7
    Run Software Update. There have been numerous updates to MacOS X 10.6 since MacOS X 10.6.0. Some updates address security issues that have been identified since your OS was installed.

    I had your problem a couple of weeks ago. I ran File System Check [fsck -fy] from the command line in Single User Mode. It fixed the problem.
     

Share This Page