Do I have the wifi issue?

stonyboys

macrumors 6502
Original poster
Oct 16, 2012
323
3
Just got my phone today and it looked flawless until I used speedtest just now. I have a 50 Mbps Internet plan so these speeds seem unrealistically slow. Do I have the wifi issue or is this normal?
 

Attachments

Oppressed

macrumors 65816
Aug 15, 2010
1,265
10
Just got my phone today and it looked flawless until I used speedtest just now. I have a 50 Mbps Internet plan so these speeds seem unrealistically slow. Do I have the wifi issue or is this normal?
Do you have another iOS device to run the same test. Also does your wifi router broadcast in dual band 2.4 and 5 Ghz?
 
Comment

Megalobyte

macrumors 6502a
Dec 30, 2007
690
119
Florida
Try rebooting your router, and reset network settings on the phone, then reconnect manually to your wifi. If you're still having problems you likely do have an issue, probably an incompatability between the router and phone. My belief is most of these issues can and will be fixed in an update.
 
Comment

stonyboys

macrumors 6502
Original poster
Oct 16, 2012
323
3
Do you have another iOS device to run the same test. Also does your wifi router broadcast in dual band 2.4 and 5 Ghz?
The only other iOS device I have is an iPhone 3G, is that too old for the tests to be relavant? And I have no idea what my router broadcasts, its the router/modem combo machine that shaw gave me.
Try rebooting your router, and reset network settings on the phone, then reconnect manually to your wifi. If you're still having problems you likely do have an issue, probably an incompatability between the router and phone. My belief is most of these issues can and will be fixed in an update.
I speedtested this morning and I got around 25 mpbs, which is what I expect. But I just speedtested again and it's back to being around 4, the highest being around 8. Does this mean anything? Also whats most important to me is whether or not this is a hardware issue, is there any chance of that?
 
Comment

darster

Suspended
Aug 25, 2011
1,703
1
The combo router/modems are notoriously crappy. Get a seperate router, hook up to modem and turn off the wifi router on modem.
 
Comment

darster

Suspended
Aug 25, 2011
1,703
1
Just because you have a 50 mbps plan doesn't mean you'll get that. There are tons of factors. I have a 75mbps plan and i know my phone will never get that via wifi. Hard wired maybe wifi doubt it. Your phone is fine.
Not always. My cable company provides me with 50 to 60 Mbs DL speeds. I consistently get those speeds via wifi and also ethernet connections.
 
Comment

trlyka

macrumors 6502a
Dec 26, 2011
539
7
The combo router/modems are notoriously crappy. Get a seperate router, hook up to modem and turn off the wifi router on modem.
I agree. I work for a cable provider and our Gateways suck. The reach is pathetic. Same room, ok, but after that, you won't get good wifi strength. How far are you from the router when you do the test? What does your computer get? Do yourself a favor and get a N router. Just use your current Gateway modem as a bridge. I have the 50 service too and I just got 31.92 mbsp down and 11.69 mbps up on my iPhone 5. I have a standard Netgear router I got from the cable company when they were suppling them for free.
 
Comment

smotania

macrumors member
Jun 14, 2012
86
3
Boston, MA, USA
Most likely the problem is with the router ... Probably its support on b and g standards and i dont think its a issue cuz probably u r not downloadin movies from your phone right ? 4-8 mbps its more than enough for phone :) if u have the same score with your computer u definetly have to change ur router ;) good luck
 
Comment

phillyphill

macrumors 6502
Apr 23, 2010
259
0
lorton
Not always. My cable company provides me with 50 to 60 Mbs DL speeds. I consistently get those speeds via wifi and also ethernet connections.
Yeah but we cant single out the phone. We don't know too much about the situation. Could be the phone could be the router/area.
 
Comment

trlyka

macrumors 6502a
Dec 26, 2011
539
7
Just got my phone today and it looked flawless until I used speedtest just now. I have a 50 Mbps Internet plan so these speeds seem unrealistically slow. Do I have the wifi issue or is this normal?
I assume your Gateway is a newer DOCSIS 3.0? If it's 2.0, then I think the max you get is 25 down even with a 50 service. But your phone should be getting at least 10-15 even if it was a 2.0 router.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.