Do I Need 4.2.9 to Update to 4.2.10?

Discussion in 'iPhone' started by MaxMike, Jul 28, 2011.

  1. MaxMike macrumors 6502

    Joined:
    Dec 6, 2009
    #1
    Well, I was trying to update my iPhone (running 4.2.8) and whenever it extracts the software, right after it finishes I get a message that says "The iPhone "" could not be updates. This device isn't eligible for the requested build." Is this because I am not running 4.2.9? I'm jailbroken, but I've decided that for how my phone is, I really don't need it to be jailbroken. Especially since iOS5 will have an equivalent to LockInfo. Thanks for any help!
     
  2. jpetticrew macrumors 6502a

    jpetticrew

    Joined:
    May 13, 2009
    Location:
    Texas
    #2
    You need to go in and change your hosts file back to the way it was. I don't remember exactly what to change, but iTunes is looking to Saurik's server and it needs to be looking to Apple.
     
  3. MaxMike thread starter macrumors 6502

    Joined:
    Dec 6, 2009
    #3
    OK, thanks. I was actually having some intermittent happenings anyway so I think I'll just restore my iPhone with the new software.
     

Share This Page