do i need same version of iphone software before restoring data?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cleung, Jan 20, 2009.

  1. cleung macrumors regular

    Joined:
    Jan 11, 2006
    Location:
    Hong Kong
    #1
    My old unlocked 2G iphone is on software version 2.1. I just got a new 3G iphone which is on 2.2. Do both phones need to be on the same software, i.e. 2.2, for me to be able to restore data from my old phone? Would I need to update my old 2g phone first? Thanks.
     
  2. DPA macrumors 65816

    DPA

    #3
    Correct, when you restore, iTunes asks you if you are sure you want to restore the iPhone to factory settings and delete all data and to update the iPhone firmware. The only time it doesn't ask you this is if your iPhone is in recovery mode.

    David
     
  3. cleung thread starter macrumors regular

    Joined:
    Jan 11, 2006
    Location:
    Hong Kong
    #4
    Thanks. I've done the restore once but had the same firmware. The reason why I'm asking is because my 2G phone was unlocked using pwnage and I'm not sure I want to upgrade to 2.2 yet. So sorry for one other silly question... if I plug the new 3G iphone in with 2.2 and I ask it to restore from my backup which has 2.1, will I end up with 2.1 firmware on the 3G? I'm in Hong Kong so the 3G phone is actually a legitimately unlocked phone. If it goes back to 2.1 then I can just update the firmware on iTunes, right?
     
  4. ilfn143 macrumors 6502

    Joined:
    Aug 27, 2008
    Location:
    Enron by the Sea
    #5
    you keep the firmware, it'll only restore your data
     

Share This Page